Unable to print from LibreOffice Files

Is your question about a problem with databases (because you tagged base which is the name of the DB component)? If this is a generic one (you can’t print in Calc, Writer, Draw, …), retag for common. Also improve your question by adding OS name, LO version and printer brand and make.

This happened to me on Windows because of the low quiality of the printer drivers shipped with Windows. Install the printer driver downloaded from the vendor’s website.

Thank you Ajlittoz for your interest. I am using Libra Office 7.4. I don’t understand the bracketed question but so far I have only tried to print Libra Office Writer files. I can print scanned documents for some reason. I don’t know what OS name means. The printer is Epsom ET-2826. I rently bought this as new to try and fix the problem but still cannot print Libra Office.

Thankyou Villeroy for looking at this. I had a disk with the new printer that I thought downloaded everything. Wasn’t this the case?

What do I know about your printers? You do not even tell us your operating system.
Workaround: Export your document as PDF, open the PDF with a PDF viewer and let the PDF viewer print.

Please give the details of your operating system as requested here, This is the guide - How to use the Ask site? - #3 by Hrbrgr

Also how your printer is connected and of you have downloaded and installed the drivers for it.

OS= Operation System, so the question, if you use Windows, MacOS, Linux, NetBSD, OS/2 … After that next point is the Version like Win10 pro, Win7 home 32 bit, MacOS Ventura, MacOS on Apple M1 chip, Debian Bookworm, Linux Mint XFCE, LUbuntu 22.04, Arch Linux…

Only you can check. Often this disks have older drivers, but they may download more recent versions for install. Check what your default printer is. Can you print from other software?

Sorry. I don’t know much about computers. I have windows 10. I don’t really live on computers. I just want to be able to print what is on the Libra files.

Thank you for that Wanderer. I have just realised that. I have given the details just now above.


Thanks Wanderer.

The printer was purchased last week to try and cure the problem. Everything looked sparkly new. Are you saying that the disc may not have downloaded the proper drivers?

The download was labelled Epsom Connect 146 whatever that means. If I try and download the drivers for the printer from Epsom would that cause problems if they were already downloaded from the disc?

Many thanks,


This email did not get here by pressing reply. i have repeated it here below. sorry everyone. In future I will use the option to come straight on here and then write…

Hi Ernest. Thanks for your reply.

Does the below mean anything to you. I had to learn how to get it up.


Windows 10 System


Intel(R) Core™2 Quad CPU Q8200 @ 2.33GHz 2.34 GHz



64-bit operating system, x64-based processor

Hi Wanderer. The details are now above of my operating system. Sorry the original email did not get here by pressing reply on it. As you may gather I am not very ofay with computers or even how to use this site.

How do you export the document as PDF when it is not a pdf? Sorry for my ignorance.

There is an entry in the menu file for this. You may check the help:


Thanks Wanderer. I will give it a go.

That worked fine Wanderer. Thank you. At least I have a way to print urgent documents and not be stuck.
While I am very grateful I have a hope that I will be able to print ordinary files to save always having to convert them to pdf’s.

Many thanks again.

So we know now, your printer works. The question is, why you can’t print from LibreOffice.

So you had this problem before?
Maybe LibreOffice prints to another default printer, remembered by some older setting.
I usually hit Ctrl+P to print and get the print-dialogue then. Is your new Epson-Printer selected there? Maybe try to change to another printer (M$ also includes its own print-to-pdf), then set to the new printer again.
In the list of funny settings I have seen are Fax-printers as default; double installations, where the same printer is found twice, but only one name is active and remote printers as default (people asking why printrr won’t work, not seeing the print because thy printed to the wrong printer…
Can you take and upload a screenshot or photo of your print-dialogue?

1 Like

Also see this microsoft page for setting default printer, Set a default printer in Windows - Microsoft Support

Yes Wanderer I had the problem before that is why I bought a new printer. I will try some of the things you say and see what I can do. I am on a learning curve here but will come back to you.
Many thanks for y our efforts.