Underbraces and overbraces

On my two computers at home running Windows 8, the underbraces and overbraces in inserted formulas are in the wrong position. This happens with both the normally installed versions and the portable versions. The same portable version works just fine on the Windows 7 at work.

When I convert the file to a pdf, the braces are rendered correctly (in the pdf).

Any suggestions?

The lines in the square roots are also in the wrong place and the minus signs are taking up too much space.

Tried uninstalling and reinstalling both LibreOffice and Java. No joy. Also tried moving the user profile to a different folder and having LibreOffice regenerate it. No joy there either.

Does LibreOffice use .net? Because one thing I remember doing as I noticed the problem was installing an old version of .net so that SyncToy would work.

Weird change, the underbrace has been replaced by a box.

Which version of LO you are using? I have done some testing under Ubuntu 10.04 x86_64 + LO v3.5.7.2, Ubuntu 10.04 x86_64 + LO v4.0.1.2, and Win 7 HP + LO v4.0.1.2. There does appear to be an initial artifact issue under Win7 and a more general problem with minus sign treatment. An example of the particular formula code you are using would also be helpful. Test formula code used in the examples below:

{the brace is above}
overbrace a
{the brace is below}
underbrace {f} newline
sqrt { { { df } ( x ) } over { dx } } = sqrt { ln ( x ) - tan^-1 ( x^2 ) } newline
x - y newline
x − y newline
x {"-"} y newline
x {"−"} y newline

References are made to the LO v3.5 Math Guide. There are several potential issues, so I will address each separately:

  • Windows 8: Refer my answer here. You may have a platform-specific issue.
  • Formula spacing: Refer my answer here. There are some known issues with spacing. Again, this may relate to your situation.
  • Overbrace / underbrace positioning: I have used the (basic) example from p. 47 of the Guide. It displays as expected under Ubuntu. An ODT containing formulas created under Ubuntu, saved, and subsequently opened under Win7 has some rather bad visual artifacts e.g., as you indicate an over/underbrace does not align correctly with the related text. Editing (entering) the formula rectifies the display artifact, but this then requires the file be saved. I can find no over/underbrace related bug other than FDO#55086, which deals with overlapping over/underbraces, which I hope you are not dealing with.
  • Square root sign positioning: I have used a modified version of the example from p. 5 of the Guide. As for previous point. An ODT created on Ubuntu displays the square root crossbar in misalignment with the initial radical sign (√). This appears to be covered by FDO#60268 and FDO#61886.
  • Minus sign spacing: In terms of platform display consistency, this sign does not appear to be an issue (and I acknowledge that this was not raised as an issue). The particular character displayed though is more problematic. Currently the LO Math engine appears to convert the hyphen-minus keyboard character (U+002b) in a formula to what appears to be an em-dash (U+2014). Perhaps there is some precedent for this, but I would think it more appropriate to substitute the mathematical minus sign (U+2212). FDO#49547 appears to be related. The following formula codes all produce slightly different spacing:
  • x - y (U+002b)
  • x − y (U+2212)
  • x {"-"} y (U+002b)
  • x {"−"} y (U+2212)

The spacing issue is largely (but not entirely) influence by font (which I mention in the Formula spacing link above). This is how these formula elements display under Ubuntu. This is how these formula elements initially display when opened under Win7. And this is how these formula elements display after editing (on the left) under Win7.

I’ve updated to the most recent version of LibreOffice and the problem persists. The most telling aspect of this issue is that the PortableApps version (also of LibreOffice works fine at work (under windows 7) but has issue on my both my home computers (windows 8).

The problem can be produce with as simple a code as
2 underbrace 2

Weird change… the underbrace now seems to be replaced by a box. Is someone working on a fix?