update to libre office version has stopped saved documents printing out

Text created to a new document prints correctly, my saved documents do not.
I have used a document template for many years around 15 or so through open office and onwards. I’ve recently upgraded my Linux OS from opensuse 15.0 to 15.2 and this also revised the libre office version now my docs do not print out.
In searching I’ve found a probable cause to be linked to text frames as displays from navigator displays a hidden text frame to be present on the page. The document template I use has many styles within it, worked succesfully for many years and now is not working…
Any solutions please as rather than reformat 15 years of docs I’d change the OS back to earlier version and use one that works

Since openSUSE 15.2 as of now delivers version, I assume you got this versin - correct?

Have you tried to restart LibreOffice into Safe Mode (Help -> Restart in Safe Mode) and checked whether you can print old documents while running in Safe Mode? If that works, your problem might be a corrupted user profile.

Addition info request: Which format are you old documents using - `.odt` and any other format and is the format different from the format of new documents?

Thanks for the prompt reply.
Yes using that version, installed last Thursday and fully updated.
Tried Libre writer in safe mode as suggested with same results. Also, due to problems with update user profile was recreated and backed up data restored.
Document format is .odt if that is what you are asking and my normal procedure is to use a template doc for new docs. This displays fine and all looks exactly as with previous version, all displays correctly in print preview but only the line above the footer actually gets printed.
I tried to respond to the email and find that does not work, shame as I could attach template doc for anyone to try.
Any help appreciated, thanks

@Aventinus: Could you upload a document sample, so we can check if it is version or document related? Thanks.

Murphy strikes again. After considerable looking it appears though there should be a paperclip icon allowing me to do this within the comment creation box, sorry but there is none.
Options please?

@Aventinus - the paperclip icon appears if you edit your question by clicking the edit link below your question

Paperclip icon

image description

And regarding the email you got: This is just to inform that somebody added information **here**. You **can't** respond to these notification emails and you **can't** contact users of LibreOffice (which are the ones answering questions here) directly and individually.

Getting there now thanks.
uploaded a document for comparison. Essentially I use this as a template for nearly all my docs for the many styles embedded withinn it comparison will provide a good view of whats happening.

Where did you upload it?

I’ve just repeated the upload, Duh, I didn’t save the edit, so hopefully I’ve got it there now.

Wondering if this query has died and to reload old OS and office?

Wondering if this query has died

What do you mean by that? Do you mean that it takes too long to get a response here? And what is this template about: Is it the template used for old document, for new documents or for both? On a first sight: This is a strange template, since its settings.xml contains a printer configuration:


I was only querying whether it was being looked at, a simple ackowledgment that it was being checked out was fine.I am appreciative of some attention on my problem.
As to the document, it is a document I use as a template. It was produced as a sylesheet guide many years ago and I have used it ever since. I took the original document and removed all the text and put in placeholders in a few style. I create new docs by opening this template and immediately save as a new document and it has in place a ton of styles tailored to technical documentation. I have used and printed from this doc type for many years and now it does not function.
I do not know anything in technical terms of the doc contents, I am an end user who has happily used open office and libre office for years.
Any help to fixing the problem would be appreciated. A good starting point is whether this problem is exactly the same for you?

For some further information.
I have just retrieved a document I created in Oct 2007 that was saved as a .doc file to suit my workplace at the time. This does exactly the same as regards to printing. I can supply this document if that would be of any use.

I’m completely confused by your information. Now you start to talk about .doc file format, which do not print but you uploaded a template, which isn’t a real template (.ott) but some kind of a “sample-to-start-with”-file. Do you succeed to print your .doc file if you:

  • Load the file into LibreOffice Writer
  • File -> Save As.. and save it as .odt file.
  • Close the file
  • Restart LibreOffice
  • Reopen the file

**PS:** I got absolutely no problem to print the `Template.odt` file.

Sorry for any confusion I’ll try to simplify
Template.odt, uploaded is a base document I use for creating documents.It does not now print where it did on earlier office I had used.
A file created from the same base document 13 years back was output into MS office , edited, printed etc and loading that back to now installed office again displays in print preview and outputs nothing. I have done as requested and then saved this doc back as .odt, exactly the same. I hope this is clear

I had the reverse problem to this. My Lubuntu 20.04LTS recently updated Libre Office to version Newly-created documents in Writer would not print, but I could print those created with previous versions. My newly created documents would print out using Calligra Words. I completely uninstalled Libre Office and then re-installed Writer, still version, without the other apps. Now creating and printing documents OK.

@eianbro - your success is based on the fact that you completely uninstalled and reinstalled LibreOffice on Ubuntu 20.04 based system, which is known for many problems on initial installs (search this site for problems on Ubuntu using Ubuntu’s repositories). Most probably your solution won’t help on @Aventinus’ openSUSE based LibreOffice problem here.

I am now confused and uncertain what the actual issue is.

@Aventinus, Could you please as clearly as possible provide:

  1. Steps to Reproduce (e.g. Open “Template.odt” and Print it)
  2. Actual Result: (e.g. Printed file contains Picture with a “dog” )
  3. Expected Result (e.g Printed files contains Picture with a “cat”)


OK I’ve made a lot of progress
new doc new new texr prints fine
new doc new text and set paragraph style prints fine
noew doc new text import styles from templat.odt set text to differnt imported paragraph style, some work and some don’t
Styles with text set to gray, as a lot of those within my docs are give no output.
From the imported styles, fedit style from test para that does not print, change from grey to black and now prints
Problem could be within printer drivers or writer.
Anyone could please print template .odt to aprinter not run through hplip would be most appreciated.

To address confusion of problem
The filr I have uploaded does not print on my present setup
The print preview shows the text as expected , printer feeds right ammount of sheets but nothing is on the paper. That is a blank sheet emerges from the printer with nothing printed on it…
As per my last comment if I alter the style and change it from grey to black it will print on to the paper
I hope this is clear now.