Updated 6.4.4(attempted) unable to do anything

Comp details
OS: Windows 10 {current updates installed

I had 6.3.6 and foolishly allowed IOBIT’s updating software to update libre, I haven’t had a problem with it before so I figured it would be fine to do so now well I was wrong. The update didn’t work, I got an error asking me to redirect or select (forget how it worded it exactly) to the upgrade/install package which was under IOBIT in my computer for some reason. Even after uninstalling the program (both IOBIT and Libre) windows 10 refuses to let me reinstall Libre, it claims I must uninstall the ‘newer’ version first however there is no NEWER version anywhere on my computer. All Libre files have been uninstalled it doesn’t even show up on my program list which makes this all the more frustrating.

Tried so far but no success:
Uninstalling both IOBIT software updater & Office Libre
Cleaning / refreshing system registry
fixing/curing disk (C) of possible errors
downloading both 6.4.4. and 6.3.6. of office libre (x64) and trying to reinstall or repair the program

This can be fixed right?


Fixed it…
had to reinstall IOBIT software updater, install previous version of Libre from it then unistall both completely [again] and reinstall Libre from the website.