Upgrade Problem 4.0.0 to 4.0.1

I am Using windows 8. I downloaded 4.0.0 about a month back and when I installed it I noticed that is seems to leave 3.6.4 files on the computer. I removed all the 3.5.4 files manually and deleated the previous 3.5.4 download.

A few days ago I downloaded 4.0.1 but when I tried to install it I was asked the location of the installation packet LibO_3.6.4_Win_x86_install_multi.msi.

Naturally I no longer have this file and can not find it to download on the internet. I assumed that it must be seeing some remaining registry entry and I decided to uninstall LibreOffice 4.0.0 and then searched for and removed all references in the registry to LibreOffice 3.6.4 and 4.0.0

All to no avail. The installation of 4.0.1 is still asking for the file LibO_3.6.4_Win_x86_install_multi.msi. If I go ahead I get an error message “Error 1714. Impossible to remove the previous version to LibreOffice Contact technical support.”

It seems there is no way I can force a clean fresh install without the file LibO_3.6.4_Win_x86_install_multi.msi

Any help would be most welcome.

See this answer:

I finally worked out what to do. I searched the registry (using regedit) for any occurrence of “LibO_3.6.4_Win_x86_install_multi” and removed the entire key. I then ran a registry cleaner for good measure.

LibreOffice 4.0.1 then installed cleanly.

I hope this helps if someone else is having the same problem.

Not that I expect to solve the real problem here (MS Windows), but for the sake of completeness, old versions of LibreOffice can still be downloaded from The Document Foundation’s download archive.