Value Too Long In Statement

I’m learning to use Base and have a problem with creating a table using a .CSV file. I’ve imported the .CSV file to Calc and copied the data to form a Table by pasting it directly to the Tables area of data base. When I click on “Create”, I get a Warning message that says “Value Too Long In Statement” and proceeds to list all of the fields associated with the Calc file that I’m trying to import. I’ve alter the characteristics of every field type to MEMO [LONGVARCHAR] thinking that some of the longer texts in a couple of the cells were causing this problem but I still get the same results. I would have liked to attach a screen shot and a sample of the Calc file but when I tried to attach them, I get a error message that says I need 3 points before I can attach or upload any files. Can some one point me in the right direction and help me solve this.
Thanks In Advance,

I am experiencing the same problem when trying to enter the first record in a newly created database. The error message cries almost all the fields, even 4 that were empty. I asked my question at at Base field data errors?

I found this answer to a similar question on an open office forum

"Well, one thing the form wizard does not do is place input limits on the text boxes.

So if you have a text box control attached to a field that can take only 10 characters the control will not stop you from adding 11 - but the update to the database will fail.

You can fix this by opening the form in edit mode, select the text box controls and open the property editor. On the general tab there is a property for Max Text Length - 0 = unlimited. You can change this to match your actual field definitions and that should fix your problem. Assuming that this is the problem I suppose."

I was able to fix this same problem by changing the allowed length for text entry in one of my fields. I hope it helps.

first, you have to find the field affected. It could be only one field. Try with all of them until you catch the guilty! Then, review that entry in the database directly. Review the length of that field in the database. Could be that you have the wrong field length there. If so, edit the table and fix the length.