When I set a Heading writer adds a tabulation

Hello people,

I’m having a problem with using Paragraph Styles in writer.

I changed the font and font color of headings1 and headings2 and now after saving the document, closing and reopening it this happens: when I mark a word to be a new heading1 or headings2 it works but adds a tab to the left. (so I delete the tab manually)

How do I make this tab not enter automatically?

(In the image you can see “AAA” with the problem, and “Movendo Guardiões” fixed)

Please upload a real, small, ODF type sample file here.
And always work in the international standard, native ODF file formats.

example.odt (17.0 KB)

Here it is.

There must be something wrong with that document. When I don’t enable numbering in Tools - Chapter numbering, no tab is inserted in a heading, and that’s how it should be. I copied your text into a blank document and the strange behavior disappeared.

Since you don’t number your headings, customise Tools>Chapter Numbering or Tools>Heading Numbering depending on version.

Go to the Position tab and set Number followed by Nothing for all levels which are not numbered.

Note that this setting is independent of the paragraph style in effect at each level.

1 Like

…in version
Heading Numbering (version

I am still under and it says “Chapter Numbering”. Has it changed in 7.6+?

It solved the problem. I will keep in mind the restriction about numbering chapters/headings. Thanks.

Note that the unexpected indent is a newish bug from that has been fixed, but only for 7.6.
See Bug 151974 - “Send outline to clipboard” and pasting indents previous headings

1 Like