Where is Insert>Table of Context and Index>Table of Contents, Index or Bibliography

I have looked into the instructions for generating a table of contents and found the instructions to Insert>Table of Context and Index>Table of Contents, Index or Bibliography, but I cannot find that link. It does not appear in my “Insert” drop down.

I am using LibreOffice Version: (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win;
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

(Screenshots moved here from comment - JohnSUN)

Sorry and don’t be offended - I have to ask this: are we talking about a text document Writer?

Sorry, I don’t understand.

I am creating a document using Writer, saved using the the .odt format in LibreOffice under the format I mentioned above. That is all I can think of to answer.

Thank you, and again, I’m sorry that I doubted you! (There are times when users ask “why there is no “table of contents” menu when I use spreadsheets in Calc”. I’m glad you’re not one of them)

First of all, go to Tools - Customize - Menus tab and make sure that this submenu is in the Target list.

If this is not the case, try the Reset button or create the desired submenu yourself.

If this does not help, try Help - Restart in Safe Mode…

If this does not work, try uninstalling LibreOffice and reinstalling it (I hope you took the distribution kit from the official site?)

And of course it will be interesting to know which of this methods helped solve the problem.

Okay, sad face here. I have tried all suggestions mentioned, including uninstalling and reinstalling, and my status remains the same. I will note the version from the help screen of the version just installed from the link provided in the first answer. Then I will insert three images. One of what I found on the interweb which is what I was looking for, and which I could not find. Then a screenshot of what I found when looking for the aforementioned image, followed by what I get whjen I try to duplicate the image shown in the answer which was provided.

Longwinded? Sorry. Here they are.

(Screenshots moved to question text - JohnSUN)

What I was looking for and would like to see: ## (screenshot from YuoTube - lesson about Writer)

What I have: ## (first screenshot in the question)

And what I have trying to follow the aforementioned instructions: ## (second screenshot in the question)

Okay, the crying face is here. What about Help-Safe mode? WIKI say "Resolving corruption:
Many problems in LibreOffice can be caused by corruption in the user profile. When noticing strange behavior in LibreOffice the first thing to do is to reset the user profile. "

Tried safe mode also (as suggested in the proposed answer). Got same result.

So, could not find menu link, safe mode did not help, and uninstall/reinstall did not work. Seems weird.

No, I meant “reset user profile from safe mode” (sorry if i was not clear enough)

I hope this is the last place where there might be a bug related to LibreOffice. Otherwise, we will need to look for an error in your Windows10 - and this is an ungrateful task.

As you can see from above image. if I go To >Tools, there is no Option option, so I cannot use that method (as found in help) to reset my user profile. Is there another method?

Please forgive me, I transferred your images to the question text and slightly reduced their size

Not Tools - go to Help. Safe mode there

P.S. Looking for a bug in Windows is not an ungrateful task to someone who needs help, unless they are arrogant idiots. Which I hope I am not, because I am truly gratefull for your help. Even now, when we are not getting the results I desire. I am still grateful for your help.

Am in safe mode. Went to >Tools and cannot find Options, or Reset User Profile

Immediately after starting the Safe Mode, a form should appear (sorry, because of my local settings this is not in English, but I emphasized the item that you need)

Have tried finding user profile, in C:\Program Files (or whatever it was), but to no avail. Need better instructions than I found with Google, or more alternatives inside LibreOffice.

As an aside, I was wanting to add a footer to a page, and then page numbers. I finally had been able to add the footer from the Page Formatting window, but inserting the page number could only be done through the drop down in the tab at the top right hand corner of the footer. It was an option not in the >Insert menu. Was wondering if the absence of the option to insert Headers and Footers being missing from the drop down was related.

Ah, see your instructions about resetting the user profile from the popup window as I enter safe mode. I have done that each time previously. Just did it again to ensure I had done it, but still none of the options I desire. Possible to use the OpenOffice TOC after creating a document in LibreOffice? OpenOffice is pretty clumsy after years of neglect, but is it possible the feature is portable?

Of course, you can insert, delete and reinsert TOC at any time when working with a document. Sorry, I meant “usually you can,” but not today.

I am afraid that even the installation of AOO will not be very successful. Perhaps everything will turn out, I hope so.

While transferring your screenshots to the question, I noticed that all the menus lacked just the last few items. Not from the middle, not from the beginning, namely the “tail” of long menus.

Let’s see if the Windows settings prevent you from working. I have already seen reports that certain desktop themes caused problems with the display of some controls (including the menu)

What windows settings do you propose I edit? Another thought. Could my Kaspersky virus protection be preventing a LibreOffice module or routine from running?

May be. Wait, my friend, right now I read “Bug 129104 - When saving user-defined menus, standard menu entries are (partially) lost.”. WIth NEW EMPTY document do you see same trucated menu?