Why am I getting weird symbols when I want to use 's

Updated my LibreOffice programs last week. Now I am running into this problem in all the programs where if I use the 's it changes it to a weird symbol as seen in the picture.

What can I do to get my 's back without the weird symbol?

@melmaid, Edit the cell and press Alt+X when the cursor is at the right of the apostrophe. Click edit below your question to share the code shown. Thanks.

Assuming you’re using Windows, have a run through the 5 possibilities on guidingtech. I find often enough that Windows Update changes languages for me. Al

Still assuming Windows. When you get your language / keyboard set back to your original settings, I strongly suggest turning off the Hot Key sequence for changing language (Ctrl+Shift) unless you really, really need it.

Just a quick setting: Click Start Menu > ⚙ Settings > Devices > Typing > Advanced Keyboard Settings > Input Language Hot Keys

In the Text Services and Input Languages dialog click the tab Advanced Key Settings, select Between Input Languages and click the button Change Key Sequence to Not Assigned for both and OK out.

Cheers, Al

Just Autocorrect?

  • In the menu click Tools > Autocorrect Options..., select the Replace tab first, above there is language box, select your default English language (the one giving you the odd character in your example screenshot).
  • In the Replace field type variations of l's, e.g. l’, 's and see if something appears in the With field, if it does, select it in the list and press Delete. If there is nothing found, then try next option.
  • I do this anyway. Select the tab Localised Options , at the bottom there are options to change the straight quote to curly quotes, untick both Replace boxes. If you really want the curly quotes in Excel, but you see something weird in one of the boxes, then click on the weird box and select the correct curly quote from the dialog that opens. Note that if you have hunspell installed then you can use grammar options to suggest the substitution (blue, wavy underline) to curly quotes in Writer

Please provide feedback. Cheers, Al

@EarnestAl, The input line shows clearly that is an apostrophe. I would lean more toward your non-Unicode guess.

By the way, input line’s font is different in my PC.

Read these guidelines and ask a good question. In particular:

  • Share a sample file demonstrating the problem$
  • Specify the operating system and LibreOffice versions.

@LeroyG you are right it does. I accidentally reset my user profile and the autocorrect for curly quotes caught me out so it was rather weighing on my mind.

Would you mind if I reposted my answer as comment? I think it would delete your comment however.

Earnest Al what you suggested worked. Sorry for the late reply I have been extremely busy and just now was able to take time to try to fix this issue. For the spreadsheet doing the option with replace worked best and for the word document using the Localised Options worked to fixed my problems with that. Thank you all for your help.

It could be related to this:

LibreOffice Tips & Tricks: Replacing Microsoft Fonts

But font name don’t appear italicized. So Arial is there for the cell, but could be an in-cell font partial change.

Ê is U+00CA.

Maybe it is an ancient version (non-Unicode) of Arial installed?