Why am I not able to change the color of font?

I have a text document in which some of the text is a yellow color. I have highlighted it, and via the menu, changed the text color to black, with no highlighting or background color. But the font color hasn’t changed.

Thanks for any help!

If you need to change the font color:
Select text > Format > Characters > Font Effects > Font color > choose black

If you need to change the “background color” = highlight color:
Select text > Format > Characters > Background > choose the background = highlight color you need

If this is not the solution, please clarify:

  • Is the font yellow or the background?
  • How exactly did you try to make changes and what are the results of each step.

EDIT
The screenshot you provided has vertical lines at the left side. This indicates that the Record Changes function is switch on.
Please see if Edit > Changes > Record is checked. If so uncheck.
Most likely also Edit . Changes > show is checked. If so uncheck.

There is also a toolbar for managing changes: View > Toolbars > Changes

Additionally
I recommend to have a look at the free guides, which you can download from http://www.libreoffice.org/get-help/documentation/

I tried the above, and it does not work. The font is a yellow color. I have changed it to black, with a white background, nothing is different, it does not work.

Thank you!! Yes, I had Record Changes selected. Unchecking that fixed the problem. I appreciate the help, thanks again.

Thank you, I had a similar issue and unchecking that resolved it.

this is an image of the page, on which i am trying to change the font color…

i tried the above methods but the font color remains the same

Screen Shot 2015-04-18 at 1.37.21 PM.jpg

i would love to include an image of the page but am unable to figure out how…

Try “Clear Direct Formatting” and then checking whether you can change the font color. I can’t explain why this may work but it did for me (for a similar issue in Calc)

didn’t work for me

i tried the above methods but the font color remains the same
As I have noticed, when the selection is lost, its gets back to its old colour.
Please resolve this issue.
OS: win7
LibreOffice: 6.0.7

My system:
LibreOffice Calc version: 5.1.6.2
Operating system: Ubuntu 16.04 LTS

Here is what I have found.
The following menu item was checked in my LibreOffice Calc:
View > Value Highlighting

Not sure if I set this at some time in the past or is part of ongoing updates.

Regardless, LibreOffice calc was set to highlight the values; that is to say, manually entered values in the form of numbers (1,2,11,42,etc) are shown blue and calculated values are shown green with common text shown black. I like the feature, so I left it as such, but found that my choice of text font colour would not show. That is, different colours of my choice that I have set for the text would not show up on the screen.

I have unchecked:
View > Value Highlighting
and now the font colour changes show up that were manually set in the past.

1 Like

Thanks @HardyN, I have the Value Highlighting enabled too…so disabling it shows the font color. I’d like to upvote you if I can but turns out I have to have more points before I can upvote.