Why are my headings not appearing on Navigator?

Hello. I have been working to make sure my headings appear on Navigator. Its disappeared. I tried to fix it but I don’t know what’s going on. I can’t explain well. I put my chapters into headings for easy navigation. It worked just fine. Then it disappears from navigation panel. Even though i right click to make sure the Headings are working, it seems to be but it vanished from the Navigation panel. And when I make a new libre office document to copy and paste, it works for awhile and then it doesnt show up on navigation anymore.

The thing is though, Heading One and Two doesnt appear anymore on Navigation panel but Heading Three seems to be working just fine.

What is going on?

Please upload an anonymized sample file, thank you.

1 Like

First to check is if the respective Heading N paragraph style has proper outline level assignment (which, by default, is controlled by Tools|Chapter Numbering feature).


1 Like

I apologize but this is still confusing to me. My simple fix would be to just copy from the original and paste it into a new libre office file. Delete the old one or save over the old one. But I paste it as an unformatted text so I can add the headings later. It works for a while. And hope the Navigator panel doesn’t break. And it still gives me one giant mystery as to why my Navigator panel keeps breaking.

I guess my question is how do I prevent that from happening or maybe it’s a bug and I have to report the bug?

Considering the huge number of people for whom the feature works nicely, you probably have broken something in the heading machinery. I suspect either a bad use of styles or some spurious modification caused by undesired direct formatting. The only way to tell is to analyse your document (if it is smaller than 5 pages).

I wonder. I’m still using 7.2 edition. Do I need to update to the recent one? I think it’s just a glitch. Cause, it happened again. The file I’m working on disappeared while I was watching something on Disney +. So when I re opened it, the headers disappeared from Navigator. Heading 1 and heading 2 is still in effect, its just not showing up on Navigator. Maybe I just need to update it?

I don’t think I broke it, so I don’t appreciate the assumption that I have no clue what I’m doing. Its probably glitched and maybe I just need to update it. Also, I’ve been writing this story for a long time so it’s more than five pages. I had like ten headers showing up on Navigator and they keep disappearing. So, maybe I just need to update it. See if that works.

Thank’s for all the help though. I appreciate it!

You can create a copy of your file.
Then delete e.g. from page 6 to the end and save the copy.
You can now upload the copy here.

To do this, click on the three dots or the pencil, or the edit icon under your initial question. What is available.
In the edit mode of the question, select the upload icon.
Select your file and click the Upload button.
Thank you.

In which file format do you save?
Which operating system do you use?

But the new version will resprct a wrong setting done before. So this usually helps, if you are not the only person with the problem.
Have you tried the safe mode?

What is the file format?

No. In most cases, problems in LibreOffice are caused by a corrupted user profile, and not by a bug in the core software. In that case, re-installing or installing a later or older version doesn’t help at all, because the user profile is not affected by uninstalling and installing of LibreOffice. See LibreOffice user profile - The Document Foundation Wiki for help. Note: you rename the old profile, so your user settings are safe, and you can later copy them from the old profile to the new one. Do that when LibreOffice is not running.

All users who have so far replied, have probably been at that point where they had to admit that they were clueless. I have. You don’t need to be ashamed or feel bad about it.

Maybe something got broken in your document. It happens. The only way to make sure what is going wrong in your document, is to allow people to inspect (part of) it. If they can reproduce it, something is wrong in the file - either the coding or the formatting; if they can’t, it’s something on your computer. If you want to submit a bug report about it, the developers will want a sample document anyway.

The one that I bolded. That suggestion actually worked. I mean, I just copied from the old file and pasted on notebook. Then I exited Libre Office and re opened a new file from Libre Office. Then copied from the notebook into a new file. It seems to be working. So far. The file I’m talking about has the broken headers thats not appearing on navigator. It works everywhere else, but not this one. What I just did from the bolded suggestion is actually working. So far. So, it must be something from the old file thats probably corrupted or something. So, I just copied and pasted on notebook and repeated it on the new Libre office file. The headers seems to be appearing on Navigator. So far…

Thanks for the suggestion!