Why does the Notification Javascript no longer Work?

A couple of days ago I came here & was informed that the entire site was “Read-only”, and no changes would be accepted. A day later & I needed to re-login into the site. From that moment the “Notification” page-JS no longer works (and, therefore, I cannot remove the notifications). Why not?

Extra Info:

The Ask.LibO system makes a note of every question that a user answers or modifies. Then, if anyone else answers or modifies one of those same questions, it puts a link + snippet of that answer/mod into a “Notification” section of the user’s Profile + a visual notice (((https://ask.libreoffice.org/m/default/media/images/mail-envelope-full.png?v=20)) next to the username to show that new responses are available. Each snippet contains a checkbox. Above all the snippets are " mark seen | delete select: all | none " option-links which act on the snippets. The entire process is mediated via JavaScript and, until recently, for me worked flawlessly.

(February 3 update): To be clear, “select:all” and “select:none” both work fine. However, “mark seen” and “delete” do nothing.

I guess that only @evgeny1 or @floeff can answer this.

Tuesday 26 Jan Update:

I stopped answering questions when this happened, else the Notification page would become a nightmare for me. Nevertheless, now there are 16 Notes in my profile, and growing. I cannot dismiss any of them

No-one else saying “Yup. Affects me too” so I must be alone in this. Oh dear.

Tuesday 02 Feb Update:

The system forced me to re-sign in; I was hopeful of a system change because of this. If so, not to this issue. No change to JS failures, and it is impossible to dismiss the Notifications.

Thursday 18 Feb Update:

One full calendar month since notification. The system forced me to re-sign in. No change of any kind. Nothing from any Administrator.

The way that you know something is dead is that you poke it very hard. If it does not respond, it is dead.

Thursday 3 Mar Update:

Hooray! The Notification system now works since Feb 29 (see my comment to the accepted answer).

If the visual notice next to your username (((https://ask.libreoffice.org/m/default/media/images/mail-envelope-full.png?v=20)) still exists, then it is simply that there are so many non-dismissed notifications stacked up against your name. I had to do the following in my Profile many, many times before it finally went:-

  1. Go to the notifications tab
  2. Click on “select: all”
  3. Click on "delete"
  4. Go to the overview tab
  5. (rinse, repeat)

23 hours, zero response.

47 hours, still zero response. Problem continues.

Still the same.

Please get it fixed as I have loads of notifications I need to delete.

Any news about a timescale to fix the problem?

Tried to report this on the “give feedback” link but this also not working get “Internal server error”.

Have reported this on bugzilla as LibO bug 97503. See whether this can provide an answer.

Following my reporting this problem as a bug, I was requested to file a report on redmine. Task #1756: Notification on ask.libreoffice.org no longer works - Infrastructure - The Document Foundation Redmine

I will update this problem when I have further news…Peter

March 3

As Alex has already reported, the notification and send feedback problems have been sorted. I have sent thanks to Alex W, confusing to have two Alex’s, who managed the redmine end.

Excellent! Thanks Pete. And, with a response time of 23 days to the original notification, I guess that I can go back into hibernation.

It has been assigned, hopefully it will go right soon!

Until 47 hours ago, Evgeny’s Profile reported “Last seen: Jan 16 '16”. It now says “47 hours ago”. And yes, now mine is working too.

As detailed here (Q60783) Evgeny’s Profile is also corrupt, and thus my earlier link for him actually directs to a completely different evgeny. The one in this comment is OK.

Perhaps try deleting the browser cache? I used to delete notifications, but now I just mark the notices as seen. Does this alternate action work?

EDIT: I can confirm (via phone browser, which is fairly broken anyway) that both indicated actions no longer work. Now tested using a Iceweasel under Debian GNU/Linux. Same result. Seems broken since the recent upgrade.

I’ve given the 2 Administrator links in my OP (@evgeny1 and @floeff). They are the only ones that can fix this.

Working for me today!!