Why is copy protection removed when I save a file?

Using Linux Mint 13 Cinamon and LibreOffice (100% Linux machine)
A friend sent me a CD with a password protected file written in Microsoft Word. The file on the CD was indeed password protected (I opened the file with LibreOffice Writer and tested it). I saved the CD file to my hard drive in odf format. Next I opened the file on my hard drive with LibreOffice Writer and all security was gone. I could type text or edit graphics at will.

My question is How could this happen? This is a very important issue as the file is a professional document that represent years of research and is copyrited.

Does it have something to do with saving a word file to odf format?
Thank you for your help

Please explain in details all steps you did when “… saved the CD file to my hard drive in odf format.” I assume that there is the problem because the file on the CD is a doc-file.

My error. File was saved to odt (LibreOffice Writer format). Here are the steps. 1) insert CD with MS Word file in CD drive. 2) open the word file using LibreOffice Writer 3) File/Saveas/Home/Documents/OriginalFilename.odt 4) close file. 5) Remove CD from CD drive and close drive. 6) With LibreOffice Writer I Open the saved LibreOffice Writer file Home/Documents/OriginalFilename.odt. 7) I was reading the document and when I went to close the file I was prompted to save changes. I was surprised because the Word Document was password protected. 8) to check I typed the word “Test” at the top of a page, saved the file cand closed LibreOffice Writer. 9) Using LibreOffice Writer I opened Home/Documents/OriginalFilename.odt that I had just saved and the word “Test” that I had typed was saved in the document. 10) I inserted the CD into the CD drive and opened the original MS word file using LibreOffice Writer and tried to type the word “Test” but was immeadeately prompted for a password. 11) to me this proved that the original or source file in MS word ws indeed password protected.
This is a serious security problem and I tried to post a bug report at Bugzilla but since I’m new to Linux and LibreOffice I’m not sure that I was succesful as their form is very difficult to understand to me.

After open with 3.5.7 a password protected .doc file and trying to save as:

  • .odt, it asks the password to the new file (An Odf format).
  • .xlsx, it’s no possible to select password protection (Not an Odf format).

I think 3.5.7 hasn’t implemented save docx/xlsx files with password.
You can do it with latest versions like 4.2.4.
So the only way is update your LibreOffice version.

LibreOffice Writer has an option check box in the lower left Save As Dialog to save with password and my version works. I mistyped odt as odf in my original post. I was able to copy an excel spreadsheet that was password protected to my Linux machine and then open it with LibreOffice Calc then save it to LibreOffice Clac .ods format and it retained the password protection, i.e., Everytime I open the file i am still prompted for the password. I ecpected the same behavior in writer as I had seen/experienced in calc.

@Thumbs - Did you make a test using a doc-file and Writer? If so it would be nice if you would share your experience with others. Thanks in advance!

My response to your original request was such a test. The original MS Word file is a doc-file that was password protected. I converted it to a LibreOffice Writer odt format when I saved it. I probably should have written it out as: MS Word File, TextDocument.Doc opend using LibreOffice, then saved as TextDocument.odt - this is I expected the file to be saved with the original password protection. However, when I opend TextDocument.odt using LibreOffice Writer there was no password protection.
The 1 Answer above may be the answer I’m looking for - I still need to update LibreOffice 3.5.7 to 4.2.4 but I am not sure how to do this properly. I have another question posted requesting instructions on the best way to do this. My search of the web for update instructions returned several conflicting answers. I am new to Linux and one of the frustrating things about learning is all the jargon and assumption by many that we understand everything - but that’s my learning problem and aI’ll deal with it. As soon as I find out the best safest method of upgrading I will and then post back here to let people know if that fixed the problem associated with the removed password protection.

I have concluded that mariosv’s answer above is probably the best explaination to my original problem. However, I still think this issue should be considered a bug and as soon as I figure out the Bugzilla page I will submit a bug report.

Meanwhile my post as a new question on instructions for upgrading LibreOffice that is part of my Mint debian distribuion
was answered by David and his information also helped give me a better understanding of how Linux works.
I would provide a link to his answer ut don’t yet see how to do that but if you are interested search for “Upgrading LibreOffice in Mint 13”. Posted and answered on May 25, 2014.

My thanks to all who have helped.

[How to Upgrade LibreOffice in Mint 13](https://ask.libreoffice.org/t/how-to-upgrade-libreoffice-in-mint-13/8618/2)

How to Upgrade LibreOffice in Mint 13