Why is LibreOffice converting all of my .odt documents to Word even though I never work in Word?

I’m working on MacBook Air OS Sierra 10.12.6, and when I click to open a document, instead of it opening in LibreOffice, it’s converted to Word. How do I go back to working strictly in LibreOffice?

Fantastic description! So you declare that it’s LibreOffice that does that, not some configuration of your OS (possibly made by Word, when it was installed/run) that re-associated ODTs to be open with Word? :smiley:

Hello @Osbey,

Also relating to your previous question here : How can I make LibreOffice my default for opening documents?

In this case i suspect that it is MS Word that converts your files, not LibreOffice.

When you installed MS Word, i think that MS Word just changed all file associations for itself.

The proper way to set your file associations back to LibreOffice, depends on your Operating System.

For example you could try right-click on your document, then choose “Open With…” or “Open With Application”, then select LibreOffice Writer.

HTH, lib

Resolved the matter by disabling Word.

So Microsoft is forcing Windows file association by default when installed on a ne computer (or used computer) and modifies file associations on Windows when detecting new desktop suites like Libre Office??Is this legal??

First, the original question is about macOS, not Windows. But - why would it be illegal? they don’t disable anything; I believe there’s no legislation that would ban that.