Writer on Windows 10 constantly freezing

Since yesterday Writer freezes up completely within a few seconds, or if I’m lucky minutes, on both DOC and ODT. I can’t detect any pattern to this behaviour. Once it happens I have to kill the process, then restore the file. I’ve tried entering Safe Mode and disabling hardware acceleration, and also deleting the user profile, but this has no effect.

I’ve got a new and pretty clean system, with no recent software installations except Microsoft updates, namely the May ‘Feature Update’ 2004, and the 2020-05 .Net framework one. I’m a bit suspicious about 2004, but whatever the cause, does anyone have any ideas.

Installed (64-bit) couple weeks ago and was working fine until now. This has been happening for the last 2 days for me in writer. Have 12GB RAM free. Have noticed a couple of unusual things though

roughly 1GB for opening LibreOffice to the main recent documents panel.

-100 or so MB for a new document

-3GB for the document I was working on.

-soffice.bin was hogging first cpu available to it (in excess of 70% whilst other cpus were at 5%).
Tried changing CPU affinity to test theory that LO wanted to hog the first processor available to it. Changed to processor #x and x was always hogged.

-a commit of 4.3GB

After closing off all LO processes for the night the crashing went away for a couple of hours but came back again, even after closing off all LO processes continually trying again, could only go a couple of minutes before crashing again.

Version: (x64), Windows.

I’ve got the same problem with version (x64) on my desktop computer.

It only started happening after I took the proffered Windows 10 2004 feature update.

The symptoms are that LibreOffice may work for a very short time but will freeze up very quickly whenever I use the scroll wheel or right mouse button. When scrolling down a spreadsheet the row number at the right hand side goes blank. When using the right mouse key for options it also goes blank. It would appear that the save button still works, though by that time LibreOffice is unresponsive.

I found that I can avoid the freeze situation by only using the left hand mouse button and the up, down, left and right cursor keys to navigate in Writer or Calc.

I definitely won’t update my Laptop to Windows 10 2004 given the current problem.

Anyone got any clues what’s going on

may or may not be related to post titled editing, adding, deleting of some text sequences in documents crashing LO writer

I have what seems to be the same problem. After a time that seems to be random, LibreOffice can’t display anything (but I manage to do some operations blindly with only keyboard). I encountered the problem in Writer, in Calc, in Impress and even sometimes in the starting page.
I had the problem with LibreOffice 6.4.4 64bit, so I uninstalled it and tried again with 6.3.6 64bit… same problem again.
My system is a fresh Windows 10 pro on a new computer, i7, 16GB mem.

In my case, the problem appears (mostly) when I use the mouse wheel (but not always).

Just a quick update.
I uninstalled the 64 bit version of on my desktop and installed the 32 bit version and the problem remained but occurred less frequently.
I removed my wired usb mouse and tried a wireless mouse. The problem went away.
I’ve now installed the latest 64bit version, still with a wireless mouse and no problems.
I’m baffled but the problem has now gone.
(For information I also upgraded my laptop to windows 10 2004 and have had no problems with the 64 bit version and a wireless mouse).
Whilst I’m happy the problem has gone, I wish I knew why.

I’ve been tracking this problem for some time. I’m presently using LO

I have experienced Libre Office constantly locking up my full PC. But I’ve also experience other issues with FireFox and the Mate Desktop causing problems as well. But, Libre Office will definitely cause the my Fedora 35 system to lock up.

What I have seen so far is that my RAID 0 drives aren’t recognized on boot by Fedora for some reason. It can take several reboots from a cold boot before Fedora will launch properly. Then, Mate will not wake up if the monitor is shut down for 8 to 12 hrs at a time. On the occassion that CTRL+ALT+F2 works, I now have messages saying that PipeWire is having problems. Which I have noticed with FireFox when playing videos. Or trying to record audio. It just craps out. There are times that I need to log into my PC remotely through SSH, and I find that I can kill Xorg and get the system back. Or, I have to reboot it.

So, one of the things I did with Libre Office recently was change it’s save feature from 30 minutes to every 5 minutes. Why does this make a difference, esp with all these unrelated systems seemingly having seperate issues. I think what’s happening is that the system is relying on my RAID 0 data drives to be running all the time, and when they have to spin up it causes a time out. This time out is not being handled properly by something, and that causes a cascade of failures.

Why does changing the save time affect this process. I think the drives spin down in the 30 min window. They are not the primary OS drives, but data drives. So, when Libre Office saves every 5 minutes, it keeps them running. And, thus far, after 3 days of use, the system has not locked up.

Hopefully this information helps someone keep their PC from locking up as well as tracing down the problem that is actually causing Libre Office to take down an entire pc.