Writer all of a sudden starts adding many thousands of new pages

When trying to open my 44-page long document, Writer all of a sudden starts adding many thousands of new pages. This process doesn’t stop, starts from 1000, 5000 then 9000+ new pages. Cannot do anything about it. Cannot copy and paste my pages to a new document, cannot save it in a different format, looks like my computer is frozen.
Uninstalled Installed Now the count of added pages is 22000+Thousands of blank pages_Copy.odt

What’s your OS? Does the document contain macros?

Not that I know of! :wink:
No, I have not used macros in Writer. I just started using the program. I am a complete newbie.

Oh, my OS: Windows 7 Ultimate

Strange! If the document is really a 44-page one (i.e. < 1MB), attach it to your question. Do that through the edit link.

I would rather not do it. Lots of very personal information in it, describes family history.

By the way, the document contains approximately 20 pictures and is 33MB big.

Here’s a suggestion, assuming you’re not totally newbie with computers and that you saved as .odt, not .doc(x).

Make a copy. Replace .odt extension by .zip in the copy. Open with compression utility. Remove all pictures (this will create conflicts in manifest.xml but you have a more serious problem). Save. Reset extension to .odt. Does the file now open (with errors, of course since images were removed without erasing their references)?

Followed your instructions. Opened “pictures” folder after opening the original file renamed as a zip file. Removed all pictures from the “pictures” folder. Noticed that after deleting all of them the whole “pictures” folder disappeared. Renamed the file back as odt. Opened it (now it is approx 30kb, crossed my fingers and … started counting pages… now we are at 13000.
BTW, thank you for your suggestions, I mean it, it not a sarcasm. I am completely lost here.

I am Polish and my other word processing program, MS Office 2003, does not automatically recognize Polish texts as written in Polish. Tried adding additional languages, but for some reason it wasn’t easy for me to do it. Initially, LibreOffice Writer, right out of the box, recognized my Polish documents as Polish and gave me Polish spellcheck and grammar check. I couldn’t be happier! But after couple weeks it stopped letting me write special Polish characters like ą, ę, ć and the rest of them.
Tried certain things suggested by this help forum but nothing worked for me.
Eventually I stumbled upon a good solution:
When Writer stops giving me my “ą” after pressing “Alt” and the letter “a” what I need to do is:

  1. Press “Caps Lock”
  2. Press “Shift” and “Alt”
  3. Press “Caps Lock” once again, turning it off
    Then I can go back to using my “Alt” key together with whatever letter I want to modify. In short - everything returns to normal.
    Maybe pressing those keys in the combination decribed

…has some other mysterious meaning? :wink:

I think you may have something broken in your OS.

Attach the reduced 30kB file. I don’t understand Polish, so your privacy is preserved. I’ll remove the file from the question once I have downloaded it. I use Linux and I’d like to see if the same error happens here.

You apparently see a layout loop, where some content doesn’t fit into a page, and tries to go to next page, with the same result. This is a bug, and needs reporting. Without such a report, we will never figure and fix what corner-case thing is causing that.

However, you could try converting the file to another format in the hope that it would change the layout a little and resolve the problem. It may be done in command prompt, where the layout shouldn’t be a problem. You need a command like

Path\to\soffice.exe --convert-to docx path\to\your_doc.odt

I have downloaded Microsoft XML Notepad 2007 editor and using it edited content.xml file from that zipped folder. I removed the original text replacing it with four letter “a”; so now all locations originally containing text look like: “aaaa”. Renamed the resulting file odt and tried opening it with Writer. File did open and lo and behold thousands o pages were being added to it exacly as before. Hopefully someone will be able to learn something from the downloaded file.

Now how to download or attach a file…guys, please let someone teach me how to attach a file to the comment. Remember I am Polish, so your instructions have to be really simple!

Please use “edit” link of your question to edit it and use the clip tool available on the toolbar. Thanks!

The file opens fine without any problem with LO 4.x on my laptop and enters “formatting loop” on my desltop with Then @mikekaganski’s diagnostic may be the right track.


Removing the frame with “100000000000038E00000197985FEDE082C8CF15” from the content.xml may “fix” the issue for you meanwhile (note: it will remove the image from the document).

Alternatively, you may downgrade to version 6.1 which seems to not have this problem.

Thank you very much for your persistence - that would help make LibreOffice better!

Thank you guys very much for your very quick help and for giving me an effective solution. Per your suggestion I have downgraded to version and the problem went away.
Now I have to go and make some money so I would be able to support free and open-source programs like LibreOffice! :wink:

Fixed in tdf#127235.