Writer bookmarks can no longer be deleted

I’ve written quite a few books with LO Writer, and never had this problem until upgrading to Version 7. I use custom titled bookmarks as I’m working on a manuscript, so that I can easily bounce back and forth between sections. All of a sudden, none of them can be deleted. I’ve tried it from the shortcut on the toolbar and the bookmark file from the Insert menu, but the same dialogue box always pops up, and the option of DELETE remains grayed out. This is a problem for submitting a finished draft because anything like that left resident in a manuscript causes conversion problems for the publisher. Most of them prefer a .doc (Windows 97-2003) document file so that is what I primarily use. I’m unsure what happened, but I desperately need a solution on how to make bookmarks removable again.


Can you save your file in its native format, .odt and, in a copy of that, delete the bookmarks? Bookmarks in documents in .odt format should behave normally.

As a potential second option, you could download a portable version 6.4… from portableapps.com and you might be able to delete your bookmarks using that.

You should always work in the native format and only Save As [another format] at the end just prior to sending, especially for an unsupported and undocumented format like .doc (even MS Word has to convert to open it now). Unexpected things can happen on conversion and as.doc gets more out-of-date there will be more problems in the future.

Just a thought, I have the latest version of LibreOffice on one computer. I do my critical work on another computer running the stable version of LibreOffice. Cheers, Al

Al, thanks so much for your input! I tried converting the document to ODT first, figuring that would be the easiest thing to try. Didn’t work; the bookmarks were still stuck with no way to delete them. So I uninstalled LO Version 7, and after that was cleaned out, reinstalled the last 6.4 update (I keep the last couple versions on hand, just in case)… Booted up the document after installation was finished and was immediately able to delete all bookmarks. It has to be something buggy with Version 7, which I did otherwise like. In any event I appreciate your help and the quick reply, so thanks once again.

Have a great afternoon,

I’m pleased you have managed to make yourdocument the way you want it.

You say it has to be something buggy with version 7 but I think you really should have a look at this Tutorial on OpenOffice Forum about file types.

Please, please save your work in .odt and only Save As .doc to send to your publisher.

I have also encountered this problem and I think it is also a bug. But I found a solution. You can delete bookmarks one by one in the navigator menu.

@Peter80 do you want to put that as a solution?

I think this is not a real solution, it is only temporary.

Solution: upgrade to fix this bug.
Delete bookmark button grayed out is apparently a bug in
It is fixed in

I had the problem on a machine running 7.0.0 3, but copied the file to a machine running
The Delete bookmark button was not grayed out.
I deleted the bookmark and saved the file and copied it back to the machine.
The bookmark is gone, but I still cannot delete other bookmarks using