Writer erratic display, grey blocks & 'echoes' on Mac Catalina

Hello folks,

I have been using LibreOffice Vanilla (LOV) for years but recently it started behaving oddly when I open “Writer” documents to edit.
As soon as I move the mouse over the open document, large grey blocks appear, usually exactly where I want to edit, hence the mouse move. Sometimes before it goes solid grey, it flickers as if someone is using a huge “clone” tool - and parts of the document are “echoed” in the wrong place.

I am using a Mac Book Pro 15" (2017) and running macOS 10.15.5 (Catalina, latest).
Just to be sure I removed my current version of LOV and re-installed it from the AppStore. Same issue.

I have not seen any mention of this after some searching, so perhaps someone here can shine a light? It looks as if the screen buffer can’t keep up… A sample I hastily ‘smudged’ is below - not the huge cursor hanging in the void (it’s not supposed to be that large, if I use the arrow keys to bring it to a visible line, it looks normal).

Many thanks!
The Lab Hamster

Moving the Writer window to a different screen tends to refresh and draw properly, but corrupts again as soon as any mouse is moved over the document.

I notice your document is a .docx. Does it also happen with .odt files?

Thanks for the reply - unfortunately the answer is yes: the screen issues happen independently of the file format :frowning:

If set, try to disable OpenGL in LibreOffice -> Preferences -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use OpenGL for all rendering and check whether that fixes your problem (not sure whether AppStore version got this option at all).

Thanks, Opaque!
The default setting was ‘off’ - I tried turning it on, no noticeable change of the behaviour.

large grey blocks appear, usually exactly where I want to edit, hence the mouse move

Re-read your question, watched again your screenshot and: You seem to have Edit -> [X] Direct Cursor Mode enabled.

Thank you, Opaque - that is a setting I did not know about and it seemed promising.
Alas, I am using LibreOffice Vanilla and despite digging through a lot of the menus, some of them more than once… I have not been able to find this setting.
I am beginning to think that I might be better off removing the AppStore “Vanilla” and go manage the software myself instead… sigh

If you can’t find the settings, may be you want to reset your LibreOffice user profile.

This remains a mystery. The “Direct Cursor Mode” that user Opaque mentioned seemed very promising - but the “Vanilla” version that is available on the Apple App Store is so different in layout and menus that it was not possible for me to even find any such settings.

I ‘solved’ the issue by removing the “Vanilla” (App Store) version and downloaded the installer from libreoffice.org.
All good now.