Writer mailmerge gmail - no possibility to set authentication method

LibreOffice on Linux Mageia 8.
I’ve been able to send e-mails with the mailmerge facility, using the user-id and smtp settings of my ISP which is using plain text, no password needed.
Now I want to do the same thing from a gmail account using the google smtp server. But I cann’t get any mail out. I found the answer of link text , but that didn’t help.
Comparing the smtp settings of LO with those of Thunderbird, I found that in Thunderbird I need to set the authentication method to 0Auth2, otherwise sending does not work. But I cann’t find anywhere in the LO Options - Writer where to set this property, so I’m stuck there.
I need this for an application I created and that will be running on Win 10, but the problem is the same over there.