Writer numeric form control doesn't save max or min values

LibreOffice Writer I can’t save the minimum or maximum value settings for numeric and formatted form controls. I am attempting to force users to enter a temperature between 92.0 and 106.0, and I have tried setting the default to 98.6. I have tried using the spin button to change the minimum value from the -1000000 to -9999980, but when I click off the control and back again the value has reset to -1000000.


Can you upload an ODF type sample file here?

If this is a bug report, then please file it to the bug tracker.

@mikekaganski thank you for your comments. I have reset my user profile yet the issue is still occurring. I filed the bug (# 136131) in Bugzilla here: https://bugs.documentfoundation.org/show_bug.cgi?id=136131


Do not see this as a bug. Have tested and works. Have no idea why you are trying to:

change the minimum value from the -1000000 to -9999980

when the stated minimum is 92.0

Edited the controls per question:

image description

Re-attached sample ---- RegistrationForm.odt

@Ratslinger what version of LibreOffice Writer are you using? I see that the values in the numerical field form control sample that you sent me did in fact save. However, I cannot duplicate the proper function of the value bounding feature in a new numeric field control in my instance when I add one from scratch.

This issue extends to the sample that you sent back because the modifications I make to your preset values do not save. Neither the Value min, the Value max, nor the Default value save modifications.

Per your question about why try -999980 instead of my desired value? That was a sanity check to see if the issue was only related to direct keyboard input. I thought that maybe setting the value with the spin buttons might save the change for some weird reason (which it didn’t), and I only had the patience to click it 20 times instead of the 1,000,092 times to reach my desired value, especially when I wasn’t certain that it would even save once I got there (hence the -999,980).


On Ubuntu 20.04 Mate with LO v7.0.0.3 from TDF (The Document Foundation).

Have used controls for a number of years (mainly in Base) and have not, to my immediate recollection, seen your problem before. However, I also do not recall the last time I used those settings.

1 Like

This could e.g. be a Windows-only problem. Still this is definitely a problem requiring filing a bug report - that just should not happen. Any bug report is expected to contain “Has user profile reset been attempted?” part, hinting that trying that prior to the reporting is desirable. And then posting the bug report number here would help tracking its status for those who have similar problem.

1 Like