Writer single page different background colour


I’m using Libreoffice 7.0.3 on Linux, I had the same problem with the 6.4.7 I’m trying to change the background color of a document of 149 pages. I have to change the background color of the LAST page only. I followed the documentation, so when I create the new style I set the dropdown menu of Next Style to “Default Style” in the Organizer tab but when I apply it by double clicking on the newly created style with the background color, it is always applied to the FIRST page! I cliked in the last page before double clicking the style on the right panel.

Is it a bug or where am I wrong?


A page style applies to a group of pages between two “strong” forcing page breaks.

These “strong” page breaks are created with Insert>More Breaks>Manual Break, not with the common Ctrl+Enter or Insert>Page Break. The manual break dialog allows to select the page style to apply after the break.

Consequently, if your last page is not preceded by such a “forcing” page break, the page style is applied to all preceding page down to the closest forcing page break or the beginning of the document.

The Next style: parameter has nothing to do with the manual style application. It is part of an automation process where you request that a page style is effective only for one page and subsequent pages will be laid out according to the designated page style without manual intervention. This is very useful e.g. for first chapter pages where you may want to suppress header (or footer) while retaining it for running chapter pages.

If your page style has effect only on the first page (which confuses you), this is a combination of both issues: no forcing page break before the last page and automatic switch to Default Page Style after a full page-content.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

Thank you so much indeed for you clear explanation. That solved the problem indeed. Very kind by you.

You’re welcome