Writer v7.1 freezes after creating a table of contents

After I insert a Table of Contents (ToC) in Writer, I can edit the document as long as I don’t click on the ToC. As soon as I click the ToC, Writer freezes. I’ve tried it in different documents and Writer freezes each time I click the ToC. I’m using default ToC values changing only the number of included levels.

I’m using LibreOfice v7.1.5.2(x64) which was a recent update. I’ve not worked with ToCs for a while, but I’ve never had this happen before. Has anyone else encountered this?

OS: Windows 10 Pro 64 bit, AMD Ryzen CPU

Has anyone else encountered this?

No, I have tested it, Writer - With TOC.odt (11,9 KB) with a new table of contents (but without changing the layers), there are no problems.

You can do a test and start LibreOffice in Safe mode (this is not a solution).
Try the safe mode.
If the error goes away, reset your user profile.

With me:
Version: (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

I double-checked and in the ToC options, the choice to not allow changes to the ToC was selected. At some point in upgrading that option was toggled on because I’d always had it off so I could modify the ToC as I edited my document. Anyway, changing the option to allow modification made Writer act normally. But, as soon as I turned on prevent ToC editing, Writer froze.

You should “triple-check” because “read-only TOC” is standard configuration: all changes to TOC should be done though heading insertion in text or paragraph style customization.

Manually adding entries or “decorations” in a TOC is a bad idea as they don’t survive a TOC update.

This is what I mean. When this is selected as shown in the included screenshot, Writer freezes. I normally deselect this otherwise I can’t right-click the ToC to update it after I edit the document.
De-selected, Writer works fine; selected, Writer freezes.

Have you reset your profile as suggested by @Hrbrgr ? Updates under Windows are known to damage user configuration. But before losing your settings, have tried restarting in safe mode and see if problem persists?

1 Like