XML Source button greyed out, under DATA->XML Source

I made a new LibreOffice Calc document, but the XML Source button is greyed out, how can I get it to work?
(Ubuntu 17.10; LibreOffice

This was asked three months ago: Data/XML Source button disabled.


Your are right… This is a bug that has already been reported: tdf#112033


In case it helps someone, even with where the bug mentioned above is fixed, I found it still disabled… I found that this feature (and others) is disabled while Experimental Features are disabled. Go to Tool->Options->Advanced and check the Experimental Features checkbox. (this is also mentioned in the previous question Jim K links to above).

Experimental Features works amazing! I was able to import my XML data dictionary and create a spreadsheet of it instantly.

Love this feature! Really well done.

And there is more documentation here: Development/Calc/XMLSource - The Document Foundation Wiki