Ask Your Question
1

How can I set the padding of a form textfield to 0?

asked 2017-11-30 16:55:36 +0200

Bouni gravatar image

updated 2017-12-01 10:49:13 +0200

I try to create a fillable PDF form using LibreOffice Writer Version 5.4.2.2 (x64) on a Windows 7 machine.

When I create a textinput, everything looks good: Screenshot of LibreOffice

But when I export as PDF the form looks like this: Screenshot of PDF

The worst about the padding is that the default text gets invisible when I focus the textfield: Screenshot of PDF

Any ideas how to prevent that white padding/border in the textfield?

Edit #1:

I'm using Adobe Acrobat Reader DC Version 2018.009.20050

Arbeitsraport.odt

Unfortunately I'm not allowed to upload a PDF file!? image description

edit retag flag offensive close merge delete

Comments

When I tried this and then opened the PDF in Adobe Acrobat Reader, it looked similar to your screenshot of LibreOffice, not like your screenshot of PDF. What PDF viewer did you use? I upvoted the question, so now you can attach the ODT and PDF files.

Jim K gravatar imageJim K ( 2017-11-30 19:36:17 +0200 )edit

My mistake; PDF is not currently possible. Maybe we can change that. https://ask.libreoffice.org/en/questi.... Would you care to upvote the question if you agree?

Jim K gravatar imageJim K ( 2017-12-01 16:36:26 +0200 )edit

Upvoted just seconds ago!

Bouni gravatar imageBouni ( 2017-12-04 08:22:45 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2017-12-01 16:50:25 +0200

Jim K gravatar image

Not sure what is causing the difference. Here is what it looks like on my machine. The version of Reader is the same as yours.

acrobat reader

To get around the attachment limitation, this file is actually a PDF, so rename the extension when you download it. Arbeitsraport.pdf

edit flag offensive delete link more
0

answered 2017-12-01 18:50:42 +0200

peterwt gravatar image

@Bouni I found the same problem you described using the same Reader version on Windows. It may be due to the font being used for the text boxes is Ubuntu Light. The Firma text box height is too small for the text. I have increased the height and it now works. Attached the pdf as a png. Change the file type to pdf after downloading. C:\fakepath\Arbeitsraport.png

edit flag offensive delete link more

Comments

I found out that its not an issue with the font but with the frame settings, if I choose a flat frame I see this white border, but if I set the frame to none, It seems to work as expected! The only thing that is missing is transparent background, but I think I can live with that.

Bouni gravatar imageBouni ( 2017-12-04 08:24:20 +0200 )edit

It would be good to turn your comment into an answer. Then if you have enough points, mark it as correct.

Jim K gravatar imageJim K ( 2017-12-04 18:49:35 +0200 )edit
0

answered 2017-12-06 08:40:51 +0200

Bouni gravatar image

I found out that its not an issue with the font but with the frame settings, if I choose a flat frame I see this white border, but if I set the frame to none, It seems to work as expected! The only thing that is missing is transparent background, but I think I can live with that.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-11-30 16:55:36 +0200

Seen: 558 times

Last updated: Dec 06 '17