Ask Your Question
1

Impress losing sound files

asked 2018-01-23 16:59:15 +0200

Pansmanser gravatar image

updated 2018-10-17 11:17:38 +0200

The latest version of Impress (5.4.4.2) appears to lose transition sound files when the Impress file is saved.

Edit: It also loses 'system' sounds (eg 'Applause'), and forgets the 'Stop Previous Sound' command. Edit: 5.3.7 behaves the same way.

A presentation has slide transitions with sounds. The sound files (mp3) are in the same directory as the presentation. The presentation stored under previous versions works as expected, even when re-opened under 5.4.4. When the presentation is saved and re-opened under 5.4.4 ... no sound. If the sound files are re-linked, they work while Impress remains open. When the file is saved and re-opened, the transition sound is specified, but ... no sound.

This looks like a bug, unless I am missing something.

Ubuntu 16.04 LO 5.4.4.2

Now fixed in v6.1.2, which seems to be an all-round good version. Well done developers!

edit retag flag offensive close merge delete

Comments

Anyone else seeing this behaviour?

Pansmanser gravatar imagePansmanser ( 2018-01-26 18:49:32 +0200 )edit

Yes having the same problem with the latest version

tenpennys gravatar imagetenpennys ( 2019-06-17 17:54:23 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2018-03-29 18:00:39 +0200

Pansmanser gravatar image

updated 2018-08-01 19:41:43 +0200

I have written a set of macros to work around this problem. If anyone is interested, I can post them here.

Edit: Sorry for long delay. Here are my macros (if this works)...

C:\fakepath\MusicMacros.odp

There are 2 modes: play SONG and play BG. This presentation demonstrates SONG mode. There needs to be a file YeBanks.mp3 in the same directory as the .odp (I couldn't upload it - make your own). Slide 1 begins to play the mp3, slide 2 stops it.

The facility to play background music is a bit more complicated, but the comments should make it fairly clear.

edit flag offensive delete link more

Comments

Please do, since the proposed fix in your Bugreport seems to be not working.

impresssound gravatar imageimpresssound ( 2018-06-11 21:11:09 +0200 )edit
0

answered 2018-07-01 23:53:21 +0200

rmcilvaine gravatar image

updated 2018-11-20 17:55:39 +0200

The only way I can get it to work is by using version 5.1.6.2 that came stock with Linux Mint 18.3. Works great there and opens in all other versions.

Very annoying, I'd like to upgrade.

November 1p, 2018 Good news. It seems to have been fixed. Thank you!

edit flag offensive delete link more
0

answered 2018-02-21 16:37:59 +0200

Syslin gravatar image

updated 2018-02-21 16:39:37 +0200

Hello,

I have the same problem. Did you solved it?

Version: 6.0.1.1 Build ID: 1:6.0.1~rc1-0ubuntu0.16.04.1~lo1 CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; Locale: en-US (en_US.UTF-8); Calc: group

Any idea?

Thanks, Miki

edit flag offensive delete link more

Comments

Unfortunately not, Miki. I have reported a bug (https://bugs.documentfoundation.org/s...). You can save a little bit of time ... After linking to the sound file once, the next time you open the Impress file, the sound file appears to be referenced, but it is not working. Click on the reference and the drop-down list of sounds opens at the named sound. Click on that named sound and impress 'finds' it again. At least you don't have to do a full browse to the file.

Pansmanser gravatar imagePansmanser ( 2018-02-22 16:28:45 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2018-01-23 16:59:15 +0200

Seen: 662 times

Last updated: Nov 20 '18