Impress losing sound files

The latest version of Impress ( appears to lose transition sound files when the Impress file is saved.

Edit: It also loses ‘system’ sounds (eg ‘Applause’), and forgets the ‘Stop Previous Sound’ command.
Edit: 5.3.7 behaves the same way.

A presentation has slide transitions with sounds. The sound files (mp3) are in the same directory as the presentation. The presentation stored under previous versions works as expected, even when re-opened under 5.4.4. When the presentation is saved and re-opened under 5.4.4 … no sound. If the sound files are re-linked, they work while Impress remains open. When the file is saved and re-opened, the transition sound is specified, but … no sound.

This looks like a bug, unless I am missing something.

Ubuntu 16.04 LO

Now fixed in v6.1.2, which seems to be an all-round good version. Well done developers!

Anyone else seeing this behaviour?

Yes having the same problem with the latest version

Me too! V. 7.1 (2021). MP3 or Wav file inserts & plays well, but after closing & opening again, it’s not there!!! (“Link” box is not checked, though I tried with checked too, no use!)


I have the same problem. Did you solved it?

Build ID: 1:6.0.1~rc1-0ubuntu0.16.04.1~lo1
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2;
Locale: en-US (en_US.UTF-8); Calc: group

Any idea?

Thanks, Miki

Unfortunately not, Miki. I have reported a bug ( You can save a little bit of time … After linking to the sound file once, the next time you open the Impress file, the sound file appears to be referenced, but it is not working. Click on the reference and the drop-down list of sounds opens at the named sound. Click on that named sound and impress ‘finds’ it again. At least you don’t have to do a full browse to the file.

I have written a set of macros to work around this problem. If anyone is interested, I can post them here.

Edit: Sorry for long delay. Here are my macros (if this works)…


There are 2 modes: play SONG and play BG. This presentation demonstrates SONG mode. There needs to be a file YeBanks.mp3 in the same directory as the .odp (I couldn’t upload it - make your own). Slide 1 begins to play the mp3, slide 2 stops it.

The facility to play background music is a bit more complicated, but the comments should make it fairly clear.

Please do, since the proposed fix in your Bugreport seems to be not working.

The only way I can get it to work is by using version that came stock with Linux Mint 18.3. Works great there and opens in all other versions.

Very annoying, I’d like to upgrade.

November 1p, 2018
Good news. It seems to have been fixed. Thank you!