How do I import sections without getting the automatic page breaks?

asked 2019-01-15 14:53:55 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I'm starting a new project as a tech writer for a firm that doesn't want to invest in FrameMaker or InDesign, so I'm doing my best with what's available. The department would like to work at the topic level, so we can build documents for clients out of various snippets of functionality. LibreOffice looks like it would be great for this, EXCEPT, it insists on assuming everything is being done at the CHAPTER level and sticks an unwanted page break in between every imported section. I'd like the text to flow, and be allowed, as the author, to decide where and when page breaks occur. It's possible to remove the breaks manually, of course, but you second you update or re-open the master document, they come right back. I can't possibly be the first person who's ever wanted to build a document at a finer level than just the chapter. How in the world do you turn this automatic page break on import off?

edit retag flag offensive close merge delete

Comments

I made a test and can't reproduce the page-break syndrome. Therefore, I need more information on your process:

  • How are your snippets formatted? Plain text, LO Writer file? In the latter case, how is the first paragraph styled (i.e. name of the paragraph style; is there any direct formatting applied)?

  • How are the snippets "imported" into the "final" document? There are at least 2 ways to do that: through Insert>Text from File or with a master document (the "final" document) importing other files.

Please update (= don't use an answer) your question to give this supplemental information.

Note: using a wiki for a personal question is a very bad idea -- though it is not emphasized enough in the comment -- because it will prevent you from accessing advanced features of this site.

ajlittoz gravatar imageajlittoz ( 2019-01-15 18:26:48 +0200 )edit