How do I import sections without getting the automatic page breaks?

I’m starting a new project as a tech writer for a firm that doesn’t want to invest in FrameMaker or InDesign, so I’m doing my best with what’s available. The department would like to work at the topic level, so we can build documents for clients out of various snippets of functionality. LibreOffice looks like it would be great for this, EXCEPT, it insists on assuming everything is being done at the CHAPTER level and sticks an unwanted page break in between every imported section. I’d like the text to flow, and be allowed, as the author, to decide where and when page breaks occur. It’s possible to remove the breaks manually, of course, but you second you update or re-open the master document, they come right back. I can’t possibly be the first person who’s ever wanted to build a document at a finer level than just the chapter. How in the world do you turn this automatic page break on import off?

I made a test and can’t reproduce the page-break syndrome. Therefore, I need more information on your process:

  • How are your snippets formatted? Plain text, LO Writer file? In the latter case, how is the first paragraph styled (i.e. name of the paragraph style; is there any direct formatting applied)?

  • How are the snippets “imported” into the “final” document? There are at least 2 ways to do that: through Insert>Text from File or with a master document (the “final” document) importing other files.

Please update (= don’t use an answer) your question to give this supplemental information.

Note: using a wiki for a personal question is a very bad idea – though it is not emphasized enough in the comment – because it will prevent you from accessing advanced features of this site.

Same issue I am inserting sections back to back. Files are using a derivative of the same template file. I say derivative, because they all started with the same template and some files may have been tweaked along the way.
One document was OK and it stuck, a second one is adding the page break. I ended up using the file that worked as my starting point for the second document to try and eliminate the issue. The difference in files is the “second” section

@ElSid: once again, same question. How do you “insert sections”? With Insert>Text from File or building a master document with sub-documents?

@ajlittoz Not the same question. I know how to insert a section. Took me a while to figure out. You can’t select all and uncheck the flow control. In my case, I needed to click on the first top most paragraph to find the burried flow control tick mark. Wish the control all would have taken care of it.

@ElSid: this is not a solution to initial question, so copy your “non answer” into a comment after mine. Then delete the “non-answer”.

My “same question” referred to “how do you insert sections?”

Anyway, your problem description is still as obscure as before.

I had this issue and I believe I have a solution: In each of the documents to be imported you need to select the actual text to be “exported” and make it into a section.

Then when you are in the master document and importing or configuring the imported section under the filename there is a box for the name of the section to be imported. This is important, the subtle difference is that without this the entire file is imported Including an implied page break but by importing only the section from the file you appear to avoid importing the break.

This has other benefits, it means it is possible for your sub-documents to have a title page with revision notes which is not imported into the master document.

There is no “implied page break” unless you created one, either in the imported sub-document, or in the master styles which are substituted for those of the same name in the sub-doc (therefore, the importance of insuring exact identity of styles between master and sub-doc unless you know perfectly what you’re doing).
Remember that page breaks are always associated to some paragraph. You may have “imported” the paragraph hosting the break.

I’m reporting the results of a test document I have open right now. What I am seeing is that if the section in the sub-document spans the entire document then I end up importing a page break that I am unable to locate and delete. If I ensure that there is at least one line before the section in the sub-document then the page break is not imported. If I go to the master and in formats-sections I set the section field to blank (anonymous section) then the page break re-appears. Re-set it to the named section and the break disappears.

At least one of the test sections starts with a “default style” so any odd settings should affect all paragraphs, not just that one. I’m aware that misuse of “keep-with-next” can cause unexpected gaps in documents but that doesn’t appear to be the case here.

I’m also going to add that I’ve re-tried this with completely fresh files (no history, nothing imported from MS Word) and I’m not seeing a forced page break, so this disproves my “implied page break” idea, and we’re back to the idea of style configuration issues.

Attach your master document and sub-doc so that I can have a look at them.

Test outer document.odt (861.3 KB)
Description Of 3 Phase Mains Input Connection.odt (41.3 KB)

PIC menu and RS232 amendment.odt (17.9 KB)
RFG Remote and RS232 Control connector 25 (Issue 3.11 5-6-2019).odt (604.9 KB)

Just had a look at the files in the first reply.

The page break is manually added in the first empty paragraph of Description of 3 Phase ….odt. You don’t see it because there is some kind of “optimisation” such that a page break at the very beginning of a Writer file is just ignored for its page eject effect. This allows to force an initial page style change without leaving a blank page.

So, you have a manual page break which is forwarding to the including document. Since it is in the included doc, you can’t delete it here. Once deleted in the “sub-doc”, everything is back to normal.

You have no reason to use a section in the “sub-doc” because you don’t change the number of columns and you “include” everything from this file. Creating a section only makes the document structure more complex without any benefit (and even a bad impact on performance when there are many sections) and your document becomes rather unstable (personal experience - and I’m supposed to be a Writer guru).

Once I remove all page breaks in sub-docs and sections in main and sub-docs, your document size decrease from 860k to 395k (a 50% improvement).

Where a section would be legitimate is in the D-type pin description: you insert a 2-column section and you enumerate the pins one per line. Since the columns are evenly distributed by default, you’ll have a nice 13 - 12 balance before switching back to the default page (no section). Even better, list your pins in a 2-column 26-row table with automatic repetition of first row as heading so that the heading is also automatically inserted at top of each column.

You have faulty usage of frames to insert page numbers. You probably have a default page size different than mine (A4) and your text distributes differently, making your pseudo page numbers completely wrong, not speaking of total page count.

The correct way of doing this is to enable header in the page style. Then in the header itself, you insert field Page Number and Page Count in the header paragraph. I have not measured the impact on file size.

Your usage of styles is faulty. Your vertical spacing is done with empty paragraph instead of configuring it in the paragraph style. Most of decorations are done wit direct formatting instead of designing an ad hoc paragraph style or using character styles. Many paragraphs are styled Header while this style is reserved for the header (the line which is repeated at top of every page). Etc. for many other styles. You structure your document with Heading n family (good) but many levels are skipped (in the first “chapter”, you jump from level 1 to level 4). You even have an “empty” Heading 1 after “Remote Control Connector”. In fact it contains an image; it is not a heading and should be style Text Body or equivalent.

Your work architecture is not at all master + sub-documents. You Insert>Text from File'ed which results in contents duplication. When you want to maintain separate files for chapters and consolidate them in a “cover” document, you use a master document (extension .odm) which has special properties and features to reference the declared sub-documents (.odt). You can even reorganise very easily the consolidated book by moving up or down the sub-docs, which you can’t do with the Insert>… method. And your master doc is even smaller because there is no duplication.

I recommend you study how to use styles efficiently and think over switching to master + subs if this could bring you simplification (flexibility and stability) in your work.

PS: I attached the amended file Test outer document.odt (395.9 KB). Note I didn’t fix the bad usage of frames for page numbers.

Well yes removing the section would do it too, at the expense of losing the file organization I was trying to achieve.

Clearly what I actually want to do requires an actual Master document. I was unaware of this feature, so I was attempting to recreate the functionality using links.

I have a number of documents to bring up to date and they share considerable amounts of “boilerplate” text, and I wish to apply the “DRY” principle (don’t repeat yourself) to the documentation. Currently maintaining (for example) the remote control instructions, which are common to almost all user manuals, is nearly impossible as each instance has subtle differences.

I’m aware that the existing document style conventions are a dumpster fire. I didn’t start the fire. They are like that for a (bad) reason: the document originated in MS Word and has been edited by multiple people. I am not the one responsible for the rampant frame misuse, a co-worker was firmly of the belief that you should never use a simple align centre or align right when a frame could do the same job. Regarding automatic page numbers you don’t need to tell me, this is also why I’m trying to get automatic TOC elements working.

Unfortunately the heading heirachy was already broken in Word. I have an end goal of making it consistent, but I have no intention of trying to fix every single manual individually, I’d rather plan a structure like:

A title page and TOC
A linked copy of the two-page product brochure for the product in question
A section of boilerplate text that I’ve been told to put in
A section about unpacking the unit. This may need a few variations depending on the machine type
A section about front panel controls, this is common to almost all products
A section about remote control, this is common to almost all products
A boilerplate section about warranty conditions

Then I’d build up a library of sections that could be pulled together to make the manuals. By preserving links I could propagate updates across all affected manuals.

Beware of vocabulary traps! In Writer, sections are very special objects which allow you to create “sub-pages” within a continuous text sequence. I think that what you call a section should be understood in the average reader acceptance, i.e. some structured part of a book like a chapter, sub-chapter, sub-sub-… This is exactly what the master/sub-documents is made for.

When your parts are “almost” the same for all products, you can keep a single source which is made “configurable” with conditional text and paragraphs. The controlling variables are set and defined at the beginning of the master (and are thus available when the subs are merged) and the subs will show the version dictated by the variables. Tricky but very handy.

Regarding M$ Word origin, I suspected it considering the heavy use of Default Paragraph Style and the name of the cross-reference field I found. Remember that in Writer, normal paragraph style for discourse test if Text Body while Default Paragraph Style only role is to define “universal” (i.e. valid all over you book) defaults. Changing them modifies formatting in a snap.

When writing a collection of related books, composed from a library of “clauses”, it is of utmost importance to guarantee consistency across them. The safest way to achieve this consistency is to base all documents on the same template (again in Writer parlance, this is a specific type of document with extension .ott containing initial text (what users usually call a template) and styles which will be automatically shared by all documents based on the template file. The style collection will constitute the graphical charter of your company, so it has to be designed carefully. Also remember that styles don’t represent formatting (that should be a consequence of the next remark, not the starting point) but semantic annotation like heading, operating instruction, safety warning, bulk discourse, … You give these categories different attributes (like red for safety). Don’t forget that, contrary to Word, Writer has also character, page, frame and list styles so that you should never use direct formatting. Without direct formatting, modifying the styles will have immediate effect. Any DF has precedence over styles and masks style changes. A last point, if you configure correctly your template, i.e. you make it known and managed by Writer, any change in its styles will be automatically forwarding to your documents.

As you see, there is a lot to learn to make your job easy, flexible and automated. Steep curve but extremely rewarding.

I think the “conditional” thing might be beyond me for the immediate future.

Word had “Normal” and “Body text” styles. We’ve used them interchangeably, as if you just sit down and type you tend to get “normal” by default, but if you use a formatting tool you get “body text”. Its on my to-do list.

Incidentally I rather feel that when the paragraph mark button is selected it should show all format codes, not just paragraph ends. It is one of the more frustrating aspects of LO. Prior to the WYSIWYG concept all format codes were visible, and the present situation where you appear to have to infer the existance of the page break from the behaviour of text around it as if it was the gauge boson of pagination is profoundly unsatisfactory.

Update: I see the dashed line between pages and if I hover the mouse over it then it gives me the option to edit or delete it. It doesn’t alter the fact that the break is somehow coming from the linked file even though it isn’t visible in that file.

Also Ever since I viewed the file you attached my Writer starts up with the blank page shifted over to the right how do I revert this OK it seems to have gone away, but I’d like to know what page format that actually is.

Apologies. I use to display documents in “book mode” with 80% zoom factor to display opposite page on one screen. In the bottom status bar, at right, near the zoom slider, 3 icons allow you to select the document view mode: single page, multiple pages, book mode (with left page at left, right page at right and blank pages needed for sync shown).


In Writer “professional” mode, you don’t need to act on formatting marks (though it is highly useful to have them enabled to see what’s happening) because you control your document with styles only and exclusively. Refrain from any direct-formatting, all the more if you come from Word because Word has no other alternative. Only styles will allow you to centrally dramatically change your document formatting and layout without the need to modify anything in the text. If you direct format, hunting this DF manually can’t be avoided and, worse, you have no guarantee of consistency. I know, it looks like a constraint in the beginning, but once you have your template ready, it is really nice.

A bit of an update: I found the “master document” feature you described, it will take some getting used to. It is pretty much the document structure I need.

As a side effect I’ve learned about the document navigator which enabled me to remove some unwanted “bookmarks” that were probably relics of word.

The master document version showed the same behaviour of unwanted page breaks, and it does look as if they result from unwanted hidden formatting of the sub-documents. My “section” workaround helped but I obtained a permanent fix by porting the section into a new blank document leaving the unwanted break behind. If I use the new document as a sub-document the master behaves as I’d expect.

Incidentally there are some benefits to the “incorrect” way I was doing it before as the “not a master” document can be accessed without access to all the subsections. The master document is a more “pure” way though.