Ask Your Question
0

Unable to Save or Save As any document even in Safe Mode

asked 2020-06-04 18:50:30 +0200

ErnieS gravatar image

updated 2020-08-18 14:59:30 +0200

Alex Kemp gravatar image

Upgraded to latest hoping to solve the problem but it continues. OS system is Mac Catalina latest

edit retag flag offensive close merge delete

Comments

ErnieS,

Could you share the LO version you are using? See version in menu Help - About LibreOffice.

Do not use Answer to comment. You could edit your question, or comment an answer.

LeroyG gravatar imageLeroyG ( 2020-06-04 19:09:12 +0200 )edit

Most probably the problem is not with LibreOffice but with macOS - see my answer.


Please, if you ask a question here, always provide the information given in Help -> About LibreOffice. This avoids to request the information and is key to provide a sound answer in many cases.

Opaque gravatar imageOpaque ( 2020-06-04 19:37:14 +0200 )edit

The version is 6.3.6.2

Headarrow gravatar imageHeadarrow ( 2020-06-11 02:26:06 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-06-05 00:10:51 +0200

ErnieS gravatar image

updated 2020-06-05 00:15:11 +0200

LibreOffice Version 6.2.4.2

I executed as instructed: "Set Full Disk Access for LibreOffice manually in Catalina in System Preferences, Click Security & Privacy, Select Privacy, On the right click 'Full Disk Access', Click on the '+' to add a new application, select LibreOffice, Exit for settings to take effect." It did not solve the problem. I am also unable to Export a file*

I repeated above per instruction and this time it worked. Thank you Opaque for your guidance - you were a big help!

edit flag offensive delete link more

Comments

ErnieS,

Best if you post this as a comment to @Opaque answer (that worked). Great that now you can save!

LeroyG gravatar imageLeroyG ( 2020-06-05 00:24:38 +0200 )edit

And why did you add this comment as an answer?

Opaque gravatar imageOpaque ( 2020-06-05 00:25:32 +0200 )edit
0

answered 2020-06-04 19:32:52 +0200

Opaque gravatar image

updated 2020-06-04 19:40:56 +0200

Hello,

provide LibreOffice.app Full Disk Access - even if you already did that in the past (it seems (!) macOS resets permission on each update of an app having Full Disk access).

  • Apple logo -> System Preferences
  • Call Security and Privacy
  • Select Tab Privacy and scroll down to Full Disk Access in the left pane
  • Click the lock symbol at the bottom of the dialog and provide your password

image description

  • Click + icon beneath right pane
  • Select LibreOffice.app from the app list and click button Open
  • You should get the following

image description

  • Close the dialog
  • Start/Restart LibreOffice and test again

Please note If Full Disk Access is already set and you updated LibreOffice recently, remove it and re-grant.

Hope that helps.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-06-04 18:50:30 +0200

Seen: 69 times

Last updated: Jun 05