We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

How to avoid the warning ‘Missing hyphenation data’?

asked 2021-01-06 14:43:35 +0200

TAB gravatar image

updated 2021-01-08 17:03:35 +0200

How to avoid the warning ‘Missing hyphenation data Please install the hyphenation package for locale “fr”’? I don't want to install it.

Windows10.

Version: 7.1.0.1 (x64) Build ID: b585d7d90ab863bf29b2d110c174c0c2a98f3ee4 CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win Locale: en-CA (en_US); UI: en-US Calc: threaded

format *.odt

edit retag flag offensive close merge delete

Comments

Please edit your question to provide the following information: OS name (I bet you're under Windows), LO version, format you saved your document in (I bet for .docx).

Have you read the following questions?

ajlittoz gravatar imageajlittoz ( 2021-01-06 14:58:38 +0200 )edit

Windows10. LO 7.1.0.1. *.odt First ref is File-not-found; other two are irrelevant.

TAB gravatar imageTAB ( 2021-01-08 17:03:54 +0200 )edit

What's the point of your posting actually? You use a beta (or still an alpha?) build, so what do you expect?

gabix gravatar imagegabix ( 2021-01-08 18:26:05 +0200 )edit

‘You use a beta (or still an alpha?) build’ No. I use Version: 7.0.3.1 (x64) Build ID: d7547858d014d4cf69878db179d326fc3483e082 CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win Locale: en-CA (en_US); UI: en-US Calc: CL

TAB gravatar imageTAB ( 2021-01-21 22:22:02 +0200 )edit

THis is applicable to 7.0.5.2 and some previous releases as well. Still looking for a solution.

Pegdhcp gravatar imagePegdhcp ( 2021-03-25 23:01:08 +0200 )edit

Has your document ever been stored/formatted with Google Docs?

ajlittoz gravatar imageajlittoz ( 2021-03-26 07:49:06 +0200 )edit

This is tdf#137742

Mike Kaganski gravatar imageMike Kaganski ( 2021-03-26 10:52:22 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2021-03-26 09:33:20 +0200

updated 2021-03-26 10:40:53 +0200

In one of other similar questions I saw a suggestion that works for me. It is that If you use Tools>Language>For All Text menu to set the language for one of your installed, and probably expected languages and save, that file stops asking for hyphenation support.

edit flag offensive delete link more

Comments

Obviously, if I choose a language for which the hyphenation package exists, the system won't ask for it.

TAB gravatar imageTAB ( 2021-03-27 03:18:37 +0200 )edit

Obviously... The root cause of the problem I guess is erroneous languages that appears in the text out of thin air. Lots of people are mentioning "editing with Google Docs" as a reason. I do not use Google Docs, or Google Drive for that matter, for one year or so. However I use LibreOffice on macOS and Linux, and keep finding the same problem in recently edited files.

Oh well MSO and Apple Pages etc have far worse problems.

Pegdhcp gravatar imagePegdhcp ( 2021-03-31 08:38:05 +0200 )edit

No, just no. Not obvious at all.

My OS locale is Irish. My LibreOffice install is Irish. The document was created with Irish as the language for all text and it has never been anywhere near any cloud storage. Irish proofing tools are installed.

Now, suddenly today it complains about hyphenation.

I know this is volunteer support, but it’s still disappointing when people jump to the conclusion that it’s something weird the user has done. This is more likely to be caused by a change in LibreOffice or a change in the OS.

seanos gravatar imageseanos ( 2021-04-29 09:33:24 +0200 )edit

Unlike your position I am in a mixed environment (Ubuntu en_gb and macOS that is in English (with Turkish and Italian as secondary languages) but Apple irresponsibly call LANG="". I also use lots of Turkish documents. However Libreoffice (release, not beta or alpha as some people here assume) was working perfectly. Some moths ago I was forced to upgrade macOS and Libreoffice, not at the same day but probably within the same week or so which lead to this problem. I was under impression that Apple instance corrupts files, but after reading comments like yours here, I carefully checked and found files those never edited in Apple but having the same problem.

Pegdhcp gravatar imagePegdhcp ( 2021-04-29 09:49:59 +0200 )edit
2

answered 2021-03-30 19:40:48 +0200

I experienced that also and it seems that nobody here understands what it is about. I finally found out: there is a paragraph style that got the hyphenation property activated. Start from the Default paragraph style and make sure that in the tab Text flow, the Hyphenation option is unchecked.

I noticed it occurred after trying (for a short time) LO 7.1. There may be a little regression because it happened suddenly on files only created/edited with LO.

edit flag offensive delete link more

Comments

Thanks for the suggestion but very often the cause is some damage during export from Google Docs. And frequently also, the message requests a hyphenation dictionary for a language not used in the document. This is why it is very important that OP's give the full history of the file.

ajlittoz gravatar imageajlittoz ( 2021-03-30 19:53:30 +0200 )edit

Oh please don't start with that. I just told that it can happen with a file that is 100% LO. Maybe there are other corner cases but it can also happen with LO only. I experienced that. Period.

I already quit that Q&A system because of you so I'll limit my interaction with you ajlittoz.

I only registered (again) to answer the question because I experienced that, found that it was a quite recent issue and managed to fix it for my documents.

So thanks for your comment but please wait for OP's feedback, there is no point discussing it further until he confirms if it's fixed or not.

Hagar Delest gravatar imageHagar Delest ( 2021-03-30 21:09:44 +0200 )edit

@Hagar Delest: I succeeded in reproducing the behaviour but it requires to crash LO. It is probably caused by a malfunction in the recovery. I now get the warning systematically on document open for an installed language. Unchecking the auto-hyphenation box does not clear the message on later opens.

Have you experienced a Writer crash when working on your document?

ajlittoz gravatar imageajlittoz ( 2021-03-31 11:30:34 +0200 )edit

It may be possible, don't remember.

What I DO know is that the paragraph style got this options checked WITHOUT my approval. and unchecking it fixed the issue for me. I opened that file several times after doing this SINGLE change and it works fine. I don't care if it comes from a crash recovery or not.

Hagar Delest gravatar imageHagar Delest ( 2021-03-31 11:47:10 +0200 )edit

The context could help the developers to find the cause and fix it once for all.

ajlittoz gravatar imageajlittoz ( 2021-03-31 12:03:42 +0200 )edit

Then the discussion belongs to the bug report.

Hagar Delest gravatar imageHagar Delest ( 2021-03-31 12:24:50 +0200 )edit

See tdf#137742. I attached my faulty document. Attach yours to your answer so that both can be compared.

ajlittoz gravatar imageajlittoz ( 2021-03-31 12:35:01 +0200 )edit

I cannot attach the document (sensitive data). I can explain however how I found it: I noticed that all documents were not affected. Hence it was inside the document. Then, based on the bug report, I thought that it was something with the language configuration. So I took my file and deleted 50% of its content as long as the warning was displayed at reload. I ended up in a mere sentence. At this point, I checked the styles.xml and looked for anything related to language/hyphenation. I found out that a paragraph style had a hyphenate="true" tag instead of false. I changed that tag, reopened the file and the warning was gone. I loaded the original file, checked what was the option in the dialog for that paragraph style, unchecked that options (that I never activated), saved, et voilà, no more warning.

Hagar Delest gravatar imageHagar Delest ( 2021-03-31 13:56:43 +0200 )edit

Since it is reduced to a single sentence, it should not be that sensitive. If you replace the sentence by Lorem ipsum (no need to have several paragraphs, just a few words are enough), does it still happen? In this case the document should be "attachable".

ajlittoz gravatar imageajlittoz ( 2021-03-31 14:17:50 +0200 )edit

The point is that I already fixed the file, have made a backup in the mean time so don't have any copy of the file with the issue anymore. What is to be taken from all that is that for an unknown reason the tag fo:hyphenate="false" had been set to true for the paragraph style declaration: <style:style style:name="Standard" style:family="paragraph" style:class="text" style:master-page-name="">.

Hagar Delest gravatar imageHagar Delest ( 2021-03-31 14:33:45 +0200 )edit
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2021-01-06 14:43:35 +0200

Seen: 1,460 times

Last updated: Mar 30