Ask Your Question
1

Is it possible to right-align footnote numbers AND have a hanging indent for the footnote text? [closed]

asked 2014-07-05 17:09:00 +0200

usr1311 gravatar image

updated 2015-09-01 18:14:29 +0200

Alex Kemp gravatar image

Greetings.

I am using LO Writer 4.2.5.2 on a Debian (Crunchbang) system. I would like to right-align footnote numbers and wrap second lines of footnotes to the left margin of the first line. For the visually-oriented, here is the result I would like:

 98   This is footnote 98
 99   This is footnote 99, which 
      wraps to a second line.
100   This is footnote 100.

There is a hack on the Footnotes Help page involving tab characters before and after the footnote number on the Footnotes/Endnotes Settings dialog. This works, but gives this:

 98   This is footnote 98
 99   This is footnote 99, which 
wraps to a second line.
100   This is footnote 100.

Is there a way to get the first effect rather than the second one?

I can easily get the first effect with left-aligned footnote numbers (very ugly IMHO) using the indent feature of the Footnote paragraph style. I have played around with combining various combinations of setting tabs in Footnote/Endnotes Settings and changing the indents in the Footnotes paragraph style, but that usually just smashes everything together after a large indent (pardon me for not illustrating).

I have also played around with the Outline/Numbering feature in the Footnote paragraph style, but it seems to have no (or random) effect. Numbering/List styles allow for the alignment of list numbers, but that doesn't appear to affect footnote numbering at all. (This makes sense, actually, but I had to try it.)

Does anyone have any suggestions? I am aware that it may simply not be possible (yet, I hope), but I would like to ask those more knowledgeable before I assume that.

For the record, I have googled, I have searched the Nabble forums and this Questions area. I have noted bug 65666 which is related, but doesn't address the second-line wrapping issue.

Thanks in advance.

usr1311

EDIT 01: TESTING oweng's DOCUMENT I am editing this edit to shorten it. I made some modifications to the text of Owen's (may I call you Owen?) document, which I uploaded as hisfilename-test01.odt . The biggest problem is that things would blow up if I made changes, specifically copy-paste into the footnote. Have a look if you like, but I think I've found a solution.

EDIT 02: EUREKA? -- I THINK I'VE FOUND IT, MAYBE I will upload filename-test02.odt of Owen's document, but it works (and is stable so far, and allows copy/paste into the footnote) both in my document and in his. It has to do with the logic of how Writer spaces the tabs, which I noticed by playing around with tab and margin markers in the ruler. It works like this:

  • Set tabs (with or without a period, as you prefer) in Tools -- Footnotes/Endnotes to before and after the note, using \t . The period before the "after" tab can be used but is not necessary.

In the Footnote style:

  • On the Outline/Numbering ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-29 16:50:22.816730

Comments

It is a joy to read someone actually did research before asking a question :) +1 from me! (Don't forget to upvote useful answers and mark one that works as correct.)

bencomp gravatar imagebencomp ( 2014-07-06 09:51:23 +0200 )edit

Thanks for the update. Be aware that these settings are quite touchy. I have wrestled with them often. Try the setting on a new document. I will have a more detailed look in a day or two. Presently mobile.

oweng gravatar imageoweng ( 2014-07-09 04:47:54 +0200 )edit

Much as I appreciate your time and effort (and I do), at some point a solution that is sufficiently difficult to implement and insufficiently stable thereafter is not actually a solution. That being said, I have reason to believe that my Debian LO-W installation is fairly "non-standard" I have done some testing with your document and attached the result to the edited question above. Please feel free to scold me if I am being too free and easy with edits.

usr1311 gravatar imageusr1311 ( 2014-07-09 16:00:11 +0200 )edit

@usr1311, thanks for the update. I tested your "Edit 02" instructions and they work as expected under v4.3.0.2, with one exception: The left-aligned tab at 0 is not required. In fact, setting a tab at zero does not actually store a tab setting, however this may be an unrelated bug. There does appear to be no need to associate a list style with the Footnote paragraph style to achieve the desired result. I will update my answer.

oweng gravatar imageoweng ( 2014-07-12 04:59:03 +0200 )edit

@usr1311 please use the "mark as correct" checkmark to mark the question "solved". Thanks!

bencomp gravatar imagebencomp ( 2014-07-12 10:51:08 +0200 )edit

@oweng, thanks for catching the unneeded tab, and for all your help. @bencomp, thanks, will do.

usr1311 gravatar imageusr1311 ( 2014-07-12 23:15:19 +0200 )edit

The checkmark is supposed to take away the need to add "Solved" to the question :)

bencomp gravatar imagebencomp ( 2014-07-13 00:18:22 +0200 )edit

Noobs. Whattaya gonna do with 'em? :)

usr1311 gravatar imageusr1311 ( 2014-07-13 04:10:16 +0200 )edit

@usr1311 Now that is a great question that we haven't seen before! :D Thanks

bencomp gravatar imagebencomp ( 2014-07-13 10:53:42 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2014-07-05 17:29:12 +0200

oweng gravatar image

updated 2014-07-12 06:00:26 +0200

Thanks for the question. Quite an interesting and somewhat complex topic, given the banality of footnotes.

There is a hack on the Footnotes Help page involving tab characters before and after the footnote number on the Footnotes/Endnotes Settings dialog.

For the sake of others, these are the indicated instructions:

Footnote numbers are left aligned by default in the footnote area. For right aligned footnote numbers first edit the paragraph style Footnote. ... Go to the Indents & Spacing tab page and set indent to 0 before and after the paragraph, including the first line. On Tabs tab page create a tab of right type at 12pt and a tab of left type at 14pt. Then in Footnotes/Endnotes Settings dialog enter \t into the Before and After edit boxes.

This feature was the result of bug fdo#65515 (related forum thread here), but as indicated, is insufficient to allow for hanging list item indentation. The fix for bug fdo#65666 simply seems an adjunct to the original issue. Neither fix addresses the overall problem of right-aligned identifiers in lists with a hanging indent. It may have the same underlying cause as right-aligned and centred tabs in the Table of Contents being unsupported (refer bug fdo#32360).

There is a conflict between tab stops for list indentifiers and general paragraph text (list item) indentation that requires working around. There appear to be two possible solutions, but given the complexity of one of them (associated list style) I have edited my original answer to only provide the simpler one (as outlined by @usr1311). The indent / tab setting can be touchy and sometimes require double checking / resetting, but do appear to be effective under GNU/Linux using v4.3.0.2.

Simple (indent / tab settings)

This workaround involves an unusual combination of indentation and tab settings. The key is that the indentation (left / first line) be magnitudinally larger than the intermediate right-aligned tab (which is relative to the indentation).

  1. Tools > Footnotes/Endnotes... > Footnotes tab > set Before to \t and After to \t > click OK.
  2. Modify the Footnote paragraph style to have these settings:

    1. Indents & Spacing tab > Indent section > set Before text to 36.0 pt and First line to -36.0 pt (this is where the footnote text will align - be sure to allow enough space between this location and the margin for the right-aligned identifiers).
    2. Tabs tab > Delete all existing tabs (if any) and create a new one:

      1. Position of -18.00 pt (position is relative to paragraph indentation, thus effectively 18 pt in this example), Type of "Right" > click New.
    3. Click OK.

The result should be:

right-aligned identifier with hanging indentation

Here is an example ODT.

edit flag offensive delete link more
0

answered 2014-07-06 12:56:50 +0200

usr1311 gravatar image

Pardon me if I should be using a Comment rather than another Answer for this follow up, but the character limitation on a Comment was a bit cramping.

First, thank you for going to this much trouble, I appreciate it.

Second, I cannot yet report success with your method. However, I note that you are using a German(ic)-looking Lorem Ipsum, and I wonder if you are using A4 (or other) paper and with what margins. I am using US Letter size with non-default margins (d---d Yanks just won't play nicely with others ;) ), and if the tabs are sensitive at all they will surely be affected by that? Also, does it matter what Outline Level is set on the Footnote Style --> Outline and Numbering tab? I can experiment with that of course.

It is quite helpful to know that the settings for the Foonote paragraph syle and the Numbering list style work together as both/and rather than either/or. That wasn't obvious to this noob.

Reading more carefully about bug 65666, I think it is a dead end for this since it was designed to produce what I called the "second effect". That's a perfectly good way to do footnotes, just not what I'm trying for here (and as an already-solved problem, not so useful for learning).

I will continue to experiment with this and will post results when I have some. If nothing else I will post what failed, though if it works for someone, I should be able to make it work also.

Thanks again. I'll be back.

edit flag offensive delete link more

Comments

The example is A4 paper (default for en-AU locale) and the text, while a Germanic lorem ipsum as you indicate, could be anything. The Outline Level I have left set at "Body Text" i.e., turned off, as it is not necessary to to use outline numbering. I will edit my answer to include a link to the file for you to examine. Note that I am using v4.3 and that I have not tried this under v4.2, which may not support the same settings.

oweng gravatar imageoweng ( 2014-07-07 01:51:16 +0200 )edit

Thanks again. Your .odt gives left-aligned numbers with 4.2.5.2 running under Debian, as you suspected. I am going to load 4.3 ... still under Debian ... on a spare drive I have and see what it does. Since Debian is often very "conservative (i.e., out-of-date) on libraries, it may be a Debian issue. I will try it and report back, though it may take me a few days.

usr1311 gravatar imageusr1311 ( 2014-07-08 02:25:49 +0200 )edit

I have now checked it under Debian 7 x86_64 running v4.2.5.2 and it formats with right-aligned numbers i.e., in the manner indicated in my answer. Perhaps try resetting your user profile?

oweng gravatar imageoweng ( 2014-07-08 11:55:13 +0200 )edit

I tried resetting the profile using the instructions provided at https://wiki.documentfoundation.org/U... , but no help. I thought I had it working for a little while, but no, not really. More in an edit to the original question. I'll post an .odt later.

usr1311 gravatar imageusr1311 ( 2014-07-09 00:10:08 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2014-07-05 17:09:00 +0200

Seen: 1,609 times

Last updated: Jul 13 '14