Ask Your Question
0

Images slow down performace [closed]

asked 2012-02-19 02:54:56 +0200

crazykiwi gravatar image

When I make a Writer document with many images or a presentation in Impress with images on every page it slows down to an unusable state. I don't seem to have this problem in MS Office but really want to get away from it. Is there any easy way to improve the performance other than batch editing them before import? I am using unedited photos off a 5 year old snap camera. They are fairly large, but I wouldn't have thought unreasonable, because they load immediately in an image viewer. I would prefer to take the images in high quality to retain for other purposes.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-06 17:27:06.003311

5 Answers

Sort by » oldest newest most voted
2

answered 2012-02-19 13:16:22 +0200

Klau3 gravatar image

I guess your image cache is to small. Go to: Tools > Options... > LibreOffice > Memory → change 'Graphics cache' to 100 MB

edit flag offensive delete link more

Comments

Wow. I had no idea you could do this.

crazykiwi gravatar imagecrazykiwi ( 2012-02-20 01:20:12 +0200 )edit
2

answered 2012-02-19 23:45:11 +0200

cloph gravatar image

As you write the images are fairly large, then the most improvement would be gained by only showing replacement frames instead of the actual picture. So if you don't rely on seeing the actual image, but are fine with a placeholder, then toggle Tools|Options → LibreOffice Writer → View, Display: [ ] Graphics and Objects

(File|Page preview will alwas show the image no matter what the setting is in editing mode.)

And you can also add the graphcis on/off toggle to your toolbar using Tools|Customize → Toolbars, Add-button, Category "View", Command "Graphics on/off"

And while you mention you'd want to preserve the original images, I mention the Presentation Minimizer extension nevertheless (shipped by default with LibreOffice). In Impress choose Tools|Minimize Presentation… to open the dialog that lets you set the desired output format (screen, projector, print) and whether to create a new copy or modify the current file, etc.

And last but not least, the advise that fits almost every time: Install more RAM :-)

edit flag offensive delete link more

Comments

Great suggestions, Thanks!

crazykiwi gravatar imagecrazykiwi ( 2012-02-20 01:19:37 +0200 )edit
0

answered 2014-06-18 13:50:04 +0200

While the other two options actually helped a lot, this may also provide a little speed up if you include very large graphics.

Right click on an large image and Choose "Reduce image size". LibreOffice will resize the image according to its display size. I choose Lossless compression most of the time. This will reduce image quality – but it heavily improved the performance for me while reducing document size.

I use a greater Image Cache and resized images with great success.

edit flag offensive delete link more

Comments

This helped me, thanks! Wish I could upvote

Joril gravatar imageJoril ( 2016-08-09 15:05:06 +0200 )edit
0

answered 2014-11-27 17:15:17 +0200

The presentation minimizer (Tools... -> Minimize presentation) also helps: it reduces the size of all images in the presentation.

edit flag offensive delete link more
0

answered 2014-09-02 20:17:20 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

As they would say in Japan "まだまだだね。。。" which means that LibreOffice still needs to improve a lot for its performance to be as good with images as MS Office is. This is unfortunate, as I really love Open Source and free software. This is unfortunate because I really like Open Source and Free software, and I use it on Ubuntu 14.04 all the time.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2012-02-19 02:54:56 +0200

Seen: 15,753 times

Last updated: Nov 27 '14