Images slow down performace

When I make a Writer document with many images or a presentation in Impress with images on every page it slows down to an unusable state. I don’t seem to have this problem in MS Office but really want to get away from it. Is there any easy way to improve the performance other than batch editing them before import? I am using unedited photos off a 5 year old snap camera. They are fairly large, but I wouldn’t have thought unreasonable, because they load immediately in an image viewer. I would prefer to take the images in high quality to retain for other purposes.

I guess your image cache is to small. Go to:
Tools > Options… > LibreOffice > Memory → change ‘Graphics cache’ to 100 MB

Wow. I had no idea you could do this.

This option is not found on LibreOffice 7.0.2.2

Also could not find this option in the 6.4.7.2 version as well.

As you write the images are fairly large, then the most improvement would be gained by only showing replacement frames instead of the actual picture. So if you don’t rely on seeing the actual image, but are fine with a placeholder, then toggle Tools|Options → LibreOffice Writer → View, Display: [ ] Graphics and Objects

(File|Page preview will alwas show the image no matter what the setting is in editing mode.)

And you can also add the graphcis on/off toggle to your toolbar using Tools|Customize → Toolbars, Add-button, Category “View”, Command "Graphics on/off"

And while you mention you’d want to preserve the original images, I mention the Presentation Minimizer extension nevertheless (shipped by default with LibreOffice). In Impress choose Tools|Minimize Presentation… to open the dialog that lets you set the desired output format (screen, projector, print) and whether to create a new copy or modify the current file, etc.

And last but not least, the advise that fits almost every time: Install more RAM :slight_smile:

Great suggestions, Thanks!

While the other two options actually helped a lot, this may also provide a little speed up if you include very large graphics.

Right click on an large image and Choose “Reduce image size”. LibreOffice will resize the image according to its display size. I choose Lossless compression most of the time. This will reduce image quality – but it heavily improved the performance for me while reducing document size.

I use a greater Image Cache and resized images with great success.

This helped me, thanks! Wish I could upvote

As they would say in Japan “まだまだだね。。。” which means that LibreOffice still needs to improve a lot for its performance to be as good with images as MS Office is.
This is unfortunate, as I really love Open Source and free software.
This is unfortunate because I really like Open Source and Free software, and I use it on Ubuntu 14.04 all the time.

The presentation minimizer (Tools… → Minimize presentation) also helps: it reduces the size of all images in the presentation.