Pergunte aqui
1

Calc - Manipulação de data por extenso

perguntadas 2019-01-04 11:28:54 +0200

imagem do gravatar de mrkalvin

updated 2019-02-17 17:01:24 +0200

Quando uso a data no formato [dia/ "mes por extenso" / ano]

exemplo 01/janeiro/2019

Não consigo usar essa celula nas formulas.

O calc só está aceitando quando a célula com a data contem apenas números. É assim mesmo, tem como contornar isso?

aquivo de exemplo, no excel funciona normal, no calc não está funcionando:

C:\fakepath\teste data.ods

Eu uso essa formula do arquivo pra fazer outros calculos e montar um relatório, mas eu gostaria de usar a celula do mes por extenso.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Olá. Para obter esse formato, 01/janeiro/2019 vá em FORMATAR/CÉLULAS/DATA e selecione na lista um dos vários formatos desejados ou, se preferir, no campo CÓDIGO DO FORMATO preencha com DD/MMMM/AAAA

Agora, se a sua intenção é obter a data informada em uma célula e apresentá-la em outra, por extenso, use a função TEXTO. Assim:

A1 = célula que contém a data B1 = célula onde você pretende mostrar a data, por extenso.

Na célula B1 insira a seguinte fórmula:

=TEXTO(A1;"DD/MMMM/AAAA")

Também é possível você escrever algo do tipo "dia 15 de janeiro de 2019", o que se obterá por meio de uma fórmula pouco mais detalhada, como:

=" dia " & TEXTO(A1;"DD") & " de " & TEXTO(A1;"MMMM") & " de " & TEXTO(A1;"AAAA")

Boa sorte.

imagem do gravatar de JedisonJedison ( 2019-04-04 21:47:28 +0200 )editar

3 Respostas

0

respondidas 2019-01-04 11:52:15 +0200

Não funciona porque apesar de estar vendo uma data a formatação não é data:

Faça o seguinte:

Em D3 troque a formula para =DATA(B2;B3;LINHA()-2) e em D4 =D3+1 e copie para as demais.

Formate toda a área Data D/MMMM/AAAA


Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

Mas o que eu queria é que B3 fosse o mes por extenso. Na Verdade eu preciso do B3 como um mes por extenso e a coluna (E) como valores Válidos.

A coluna D, é só um meio pra eu chegar no valor da coluna (E). No que eu preciso, a formatação da coluna D é indiferente.

Mas eu gostaria de usar a celula do mes (B3) por extenso.

imagem do gravatar de mrkalvinmrkalvin ( 2019-01-04 12:11:57 +0200 )editar

Copie a Validação de H3 para B3;

Altere a formula de E3 para =OU(DIA.DA.SEMANA(DATA($B$2;SE($B$3="Janeiro";1;SE($B$3="Fevereiro";2;SE($B$3="Março";3;SE($B$3="Abril";4;SE($B$3="Maio";5;SE($B$3="Junho";6;SE($B$3="Julho";7;SE($B$3="Agosto";8;SE($B$3="Setembro";9;SE($B$3="Outubro";10;SE($B$3="Novembro";11;SE($B$3="Dezembro";12))))))))))));LINHA()-2))=1;DIA.DA.SEMANA(DATA($B$2;SE($B$3="Janeiro";1;SE($B$3="Fevereiro";2;SE($B$3="Março";3;SE($B$3="Abril";4;SE($B$3="Maio";5;SE($B$3="Junho";6;SE($B$3="Julho";7;SE($B$3="Agosto";8;SE($B$3="Setembro";9;SE($B$3="Outubro";10;SE($B$3="Novembro";11;SE($B$3="Dezembro";12))))))))))));LINHA ...(mais)

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-01-04 16:15:45 +0200 )editar

Ah... se você quer apenas que B3 apresente o mês por extenso, então basta colocar em B3, no exemplo que mencionei no comentário anterior, o seguinte:

=TEXTO(A1;"MMMM")

imagem do gravatar de JedisonJedison ( 2019-04-04 21:49:51 +0200 )editar
0

respondidas 2019-01-04 15:42:46 +0200

imagem do gravatar de Beto

Minha sugestão seria fazer assim. Se gostar complete o código da célula I3, dos meses, pois só fiz até março.

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2019-04-04 22:04:20 +0200

Agora, se você quer apenas a planilha que deu no exemplo, faça assim:

C:\fakepath\Relatório.ods

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-01-04 11:28:54 +0200

Lidas: 89 vezes

Última atualização: Apr 04