Calc very slow to start up when connected to the Internet

When opening an existing document Calc hangs for about 30 seconds. When opening a new document no problem. If I save this newly opened and completely blank document, exit and open it again it takes about 30 seconds to open.

Write does not have the problem.

If I disconnect from the Internet, the problem vanishes.

I have updated. Now running on Windows 10. Problem persists.

I have removed all old printer drives and turned printer on and off and restarted computer. Problem persists.

I have restarted Calc in “safe mode”. Problem persists.

What should I do?


Did this problem start after no problems, or is this the first you have used LO?

There is some difference when loading from the LO start window (with the thumbnails of your latest work) or when loading from the Calc window. Have you tried both? Also, do you have any macros in your My Macros & Dialogs (in the left pane of the Edit Macros IDE)? I get that safe mode should by-pass these questions, but I think it’s still worth checking.

1 Like

Thank you for trying to help me.

I have been using Writer and Calc for many years. The problem has been here for about a week.

I always open files by clicking on desktop icons or filenames in File Explorer. I am not even sure what a LO start window is or how to find it.

do you have any macros in your My Macros & Dialogs (in the left pane of the Edit Macros IDE)?

No. Tools → Macros ->Edit macros is empty expect for a Standard “module 1” empty macro. I have never worked with macros in Calc.

[Edited for clarity]

  1. Does temporarily disabling your firewall make a difference? (Opposite of expectation, but worth a try since toggles a problem area.)
  2. Disable Tools>Options>LibreOffice(Header)>Online Update.
  3. Change the name of your LibreOffice user profile file to try a clean slate there if you haven’t already. (LibreOffice user profile - The Document Foundation Wiki under Manual Procedure).
  4. Use Alt+Tab to carefully check for any windows/dialogs that might be opening at the same time but are hidden.
  5. Are you using a second monitor? Is it turned on? I’ve often thought something wasn’t starting, only to realize it was on a different monitor. I know, that wouldn’t just take 30 seconds and move, but it’s worth listing if only for others w/similar issues looking in later.
1 Like

Something with menu Edit - Links to External Files…?

1 Like

Does temporarily disabling your firewall make a difference?

Very strange result: I turn it off and Calc starts normally fast. I turn it back on, and Calc STILL starts normally fast. Very strange.

Maybe this is more of a Firewall problem than a Calc problem?

Disable Tools>Options>LibreOffice(Header)>Online Update.

It was set to “once per week”. Turning off did not make a difference.

Change the name of your LibreOffice user profile file to try a clean slate there if you

Did not try.

Use Alt+Tab to carefully check for any windows/dialogs that might be opening at the same time

Nothing here.

Are you using a second monitor?

Just a single monitor.

Something with menu Edit - Links to External Files…?

I don’t have a Edit → Links to External Files…

I have a “open remote” that is blank and I have cleared recent documents list many times.

I set my computer to sleep for an hour. When returning Calc was slow in opening again. I disabled the firewall. But this time it made no difference.

Online Update is still off.

Change the name of your LibreOffice user profile file to try a clean slate there if you

Tried that just now. No difference to the problem.

If I were you, I’d clear my firewall of any file list, then go through the annoyance of having to accept or reject every program as the firewall gives you the pop-ups when you restart your computer.

Also, you could go to C:\Program Files\LibreOffice\program and look for scalc.exe. If you find it, then open up a terminal (Command prompt) and use
> cd "C:\Program Files\LibreOffice\program"
to navigate to that directory. Try starting scalc just by entering that in. I only have a Linux machine right now, but I’m hoping that it will start Calc, possibly showing errors in the command window if it is throwing any.

1 Like

scale.exe startes a fresh Calc right away (as before)

Saving a blank Calc and staring that from prompt takes about 30 sec as before. There are no output on the prompt. And new prompt appearers right after pressing Enter.

If I were you, I’d clear my firewall of any file list

I tried turning the firewall off again, and this time it worked (fixed the problem). I am not too found of fiddling with the firewall. Worried that I just introduce a hoard of new problems. But I guess there may be no way around it. I just don’t understand that Calc is looking for.

Maybe the problem is in the template. Would you share this blank file?

The problem seems to have fixed it self.

Thank you very much to everybody who tried to help me.

Summery: It definitely had something to do with the firewall. I did not have the courage or know-how to start fiddling with it, so I just lived with it until now where the problem seems to have gone away.

I do have exactly the same problem. Since around two weeks calc hangs for around 30 sec if I click on an existing ods file. If I run LO from the start menu and say “File | New Spread Sheet” the empty sheet opens very fast as usual.

If I click on an existing xslx file calc opens it fast as I am used to from the past. Seems the error is file format dependant.

To make things even more strange since around 14 days another program on my computer (MagicMaps Tour Explorer, a viewer for topo maps) also hangs for about 30s before it continues operation. So the problem is not specific to LO.

When I shut down my WIFI network both problems disappear: LO opens ods files fast and Tour Explorer starts as fast as usual. If I turn WIFI on again both problems are back.

My gut feeling says the error has something to do with the updates Microsoft delivered at the March 2022 patch day. I installed them at March 11th and since then I am in trouble.


I forgot to mention that I am using Libreoffice on Windows 11.

In case this helps anyone, I experienced this exact issue with a lengthy delay whenever opening an existing document with Calc on Arch Linux, LibreOffice version (New documents were unaffected same as the OP.)

I didn’t actually have any printers configured since I don’t print from this machine, but based on the description of the issue and solution in this thread, I figured the delay could be a printer-related timeout. I was able to replicate this delay whenever opening the Print... or Printer Settings... dialogs from the File menu.

The issue was resolved simply by installing CUPS and starting the service. When the service is stopped, the issue resurfaces until the service is started again.

I suspect this solution should work for anyone else who is seeing the same behaviour from Calc on any other flavour of Linux when a print server/spooler is not present.

OK, I found a solution that works at least for me. I have a network printer which is connected to my WIFI and is my default printer in Windows. If the printer is turned on everything is fine. Libreoffice calc opens existing spread sheets well and also my other application (Magicmaps Tour Explorer) starts up fast. If the printer is offline opening spread sheets hangs for 30-60 seconds. The same for Tour Explorer. Obviously some applications try to connect to the default printer and if it is offline the app hangs till timeout. The solution for me was to set “Microsoft Print to PDF” as my default printer because this one is network independent and always available. If you use “Let Windows manage the default printer” you should turn off this option.




This is tdf#42673.


Excellent, kuno.kugel. This seems to work. Thank you.

The problem came back again after a few weeks off. (Our printer seems to have a will of it own about staying on the network.)

Now I have set CutePDF as default printer. A blank Calc saved with no content opens at normal speed now. The documents I often use seem to have a saved printer. If I change that and save, they open again at normal speed.

I can live with having some PDF-printer as default. I rarely print anything.

Strange that turning of the firewall also solves that problem.

Thank you so much, turning on my printer did it for me, but changing the default printer and the defaults did not change anything for me, as I still had to leave my printer on to load my spreadsheets quick.
I use an ethernet connection for my computer, but my printer is connected to it with wifi
.I did not have any problems until I got my new computer, which has windows 11, and deleted, and reinstalled LO about a dozen times trying to get it to work right.
I did find that saving my spreadsheet to an Excel .xls file, my Calc file would open right up.
After reading your answer, until someone fixes the Calc program, now I just leave my printer on and all is well now.
Thanks again!


make sure to change it in Windows, not just in libre office. you might need to turn of “windows manages default printer” option to change the default