Cannot save Draw file

I have an ODG file that gives the following error when I try to save it:

Error saving the document Problem_Example:
Write Error.  The file could not be written. 

I checked the permissions on the file, and they are fine. I also tried resetting my user profile, and that did not solve the problem.

After working with the file for an hour, I narrowed the problem down to one specific, and very odd, example. I can move a simple object in the drawing (for example, one of the red diamonds) and save the file, and no error is reported. However, if I select an open polygon consisting of two line segments (the eyebrow above the left eye), select the midpoint separating the two segments, and edit that point to change it from a “corner point” to a “symmetric transition” point, and then try to save it, the above error is reported. If I press CTRL-Z to undo the change, I can save the file with no error.

I am at a loss to explain this problem. Does anyone have any suggestions?


I’m having a similar problem, having created a multi layer page in Draw, when I add a free form line to a multi-layer page in Draw I cannot save it.

This thread is three years old, almost certainly with different version of Draw. Do you want to start a new question? Don’t forget to add LO version, operating system, etc. consider also a sample. This page tells how This is the guide - How to use the Ask site? - #3 by Hrbrgr

Try Lupp answer: Help > Restart in safe mode > Continue in Safe Mode and see if you can save the file from there. See User profile for more inforamtion

1 Like

Can not confirm the problem with your example file.
Did exactly the transformation of the left eyebrow you dscribed and save the change to the original file without a problem.

LibO V (release) under Win 10 in one of my workbench folders.

Changed File Problem_Example.odg

Did you already try to run LibO in ‘Safe Mode…’ to rule out user profile corruption?

Thank you, Lupp. I tried restarting Draw in safe mode, but the same error occurs. I am using a different configuration than you. Sorry, I should have included this information in the original question:
LibO Version Info: Version:; Build ID:; CPU Threads: 4; OS Version: Linux 3.10; UI Render: default; VCL: gtk3; Layout Engine: new; Locale: en-US (en_US.UTF-8); Calc: group
Platform Info: Version = CentOS Linux 7; CPU = Intel Celeron J1900; Gnome Version = 3.22.2

(Safe mode was not meant to mean system’s safe mode.)
Did you try the (slightly) changed example?
Unfortunately I cannot help you concerning your specific configuration. was an unscheduled bugfix-release, published 2017-08-24. Due to the release policy of the documentfoundation that’s “rather old”. You may find help from another user with a very similar system/config (??).
Did you ever try a portable LibO? It should be runnable under Wine. It was when I tried some years ago.

It’s odd, but this is the work-around I found: First I draw a polygon (open or closed). Then with the polygon selected, I click on the menu item “Modify / Convert… / To Curve.” After converting the polygon to a curve, I can then select a point on the polygon and use the “Edit Points” tool bar to change the point from a “corner point” to a “symmetric transition” point, and the file will save without an error.

Go figure…