Cleaning up a busted LO installation

Ubuntu 16.04 LTS
Cinnamon desktop GUI

My laptop came with LO 5 pre-installed. Recently I installed LO6 (without first de-installing LO 5) and things started going south. Clicking on a file name (say, ‘myfile.odt’) would only result in the LO 6 splash banner, but the app never actually opened the file, or even opened with no file loaded. And if I simply opened an app (OL Writer) and used it’s ‘file’ menu to located and open a file, it would work — if I could locate the file. There were some directories outside of /home/myuser that it wouldn’t even show me. Also, FWIW, if I used my desktop (Cinnamon) ‘start’ menu, the ‘office’ group showed icons for both the LO 5 and LO6 apps. After getting 6 installed, I never tried the v5 to see if they still worked.

Trying to resolve the issue, I sought help on the Ubuntu forums and on advice there, deinstalled and re-installed. Now, nothing works and I cannot open any LO files. No matter what method is used to start Writer, either with or without a specific document, all I can get is the splash banner. I haven’t a clue how to clean up this mess and get things working as they should, but I’m willing to go so far as to completely remove/eradicate LO completely so that I can get a clean installation as if it had never been there … but will need some guidance.

More detail on exactly what I’ve done may be found in my thread on the Ubuntu forum, at problem opening docs after upgrade of LibreOffice

Thank you for any available assistance.

Try resetting your user profile.


It seems best to just wipe out all of LO & start over. Using terminal:

sudo apt-get remove --purge libreoffice5*
sudo apt-get remove --purge libreoffice6*
sudo apt-get clean
sudo apt-get autoremove

Then using your file manager (ie Nemo or similar) make sure you can see hidden files. Then under .config, delete the libreoffice folder. This folder alone may be the source of your problems.

Then install a new version using a PPA (instructions here → “LibreOffice Packaging” team). This is same recommendation as from Ubuntu forum.

That should get you going again.

I had a similar problem recently. Uninstall everything LibO related again. Now, open a virtual terminal and run this command

whereis libreoffice

If it gives some folders, delete or at least rename them (you’ll need administrator privileges). Finally, install LibO again.

@Ratslinger - almost there! The apt-get remove, clean, and autoremove seemed to go fine. Checked between each with ‘whereis libreoffice’ and it finally reported ‘nothing’, as

ed@ed-Gazelle-00:~$ whereis libreoffice

then located the .config directory under /home/ed, and deleted the ‘libreoffice’ directory under that. Then followed up with ‘sudo add-apt-repository ppa:libreoffice/ppa’ and finally ’

ed@ed-Gazelle-00:$ sudo apt-get update
Hit:1 xenial InRelease
Hit:2 xenial InRelease          
Get:3 xenial-updates InRelease [109 kB]    
Hit:4 xenial InRelease         
Get:5 xenial-security InRelease [107 kB]     
Get:6 xenial-backports InRelease [107 kB]  
Hit:7 xenial InRelease     
Get:8 xenial-updates/main amd64 DEP-11 Metadata [318 kB]
Get:9 xenial-updates/main DEP-11 64x64 Icons [226 kB]
Get:10 xenial-updates/universe amd64 Packages [644 kB]
Get:11 xenial-security/main amd64 DEP-11 Metadata [67.7 kB]
Get:12 xenial-updates/universe i386 Packages [585 kB]
Get:13 xenial-security/main DEP-11 64x64 Icons [68.0 kB]
Get:14 xenial-security/universe amd64 DEP-11 Metadata [107 kB]
Get:15 xenial-updates/universe amd64 DEP-11 Metadata [246 kB]
Get:16 xenial-updates/universe DEP-11 64x64 Icons [331 kB]
Get:17 xenial-updates/multiverse amd64 DEP-11 Metadata [5,964 B]
Get:18 xenial-backports/main amd64 DEP-11 Metadata [3,328 B]
Get:19 xenial-backports/universe amd64 DEP-11 Metadata [5,100 B]
Get:20 xenial-security/universe DEP-11 64x64 Icons [142 kB]
Fetched 3,072 kB in 1s (1,951 kB/s)                                    
AppStream cache update completed, but some metadata was ignored due to errors.
Reading package lists... Done

But at this point, no entries of LO under the ‘start’ menu, and I see there is no libreoffice directory under /home/ed/.config

@edstevensdba Sorry for the delay. Moved over to Ubuntu 18.04 and proceeded with the process. I personally use a different method but this is the preferred for Ubuntu. Seems one last item missing. From terminal run:

sudo apt install libreoffice

That should do it. Worked for me.

‘apt install’ – that was it. Everything is working now. Thank you so much.