Continues footnote numbering problem

If the text in the footnote is in a right to left language then the footnote continue number will be flipped: 15 will be 51

LO: Version: (X86_64) / LibreOffice Community
Build ID: 420(Build:2)
CPU threads: 4; OS: Linux 6.9; UI render: default; VCL: kf6 (cairo+wayland)
Locale: ar-DZ (en_US.UTF-8); UI: en-US
Calc: threaded

OS: Operating System: Manjaro Linux
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.9.0-rc4-1-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-6300U CPU @ 2.40GHz
Memory: 11,6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520
Manufacturer: Dell Inc.
Product Name: Latitude 7480

footnotes problem.odt (38.7 KB)

You have messed up automatic behaviour of Writer by fiddling with Default Paragraph Style. You explicitly set Right-to-left (RTL) in Properties Text direction of Alignment tab. The correct setting is the default one Use superordinate object settings.

Apparently, you did the same in other styles.

This parameter is very very special. You must not change it unless you want special effects. It is even so special that it seems to be outside the standard inheritance rule (I fixed it in Default Paragraph Style but it didn’t forward to Body Text though it is not reported as being set manually in the latter).

Writing multi-lingual documents is full of traps. You manage this by informing Writer about the language. Language properties then dictate writing direction. If you force it like you did, language properties are ignored and you end up with your problem.

By default, your computer is ar_DZ, i.e. RTL. Here you want to write an English document. The simplest way to handle this is to set language to French in Default Paragraph Style Font tab. This supposes you haven’t direct formatted your document and also fiddled with the styles (notably properties in Alignment).

My advice is to restart from a blank document where you set language to English in Default Paragraph Style and you paste your existing tyext as unformatted to get rid of all style inconsistencies. Above all, don’t direct format. Learn how to use styles. If I guess correctly about your document contents, it is not a 2-page one-shot type-and-forget one. You won’t succeed without methodical styling.

1 Like

yes, in almost styles i used in my files i did that. and i start changing them, thank you for your valuable help and tips. there a file that i change that property to superordinate but it doesn’t fixed yet. i will try again and see.

" Learn how to use styles."
yes, I’m learning about them and i find that my files were in a big mess, i was using MS word before.

test.odt (10.5 KB)

in this file i did what you say but the problem still exists

I don’t see any issue here. Your sample is Arabic with note number as “Western” (=Indo-Arabic numbers, not “pure Arabic”). I added notes up to 12, I get 9, 10, 11 and 12, as expected. Since notes are Arabic, note number is at right (and, once again, this is correct).

Perhaps, you’d prefer what I call “pure Arabic” ١٢٣٤٥٦٧٨٩. In this case, make sure Tools>Options, Language Settings>Languages, Complex text layout is enabled for Arabic. This unhides extra options in many dialogs. Among them, Tools>Footnotes & Endnotes where you can now choose ١٢٣٤٥٦٧٨٩ numbering.

1 Like

the problem is here: the number is flipper
i should be: 14 and not 41
the problem is in the number near the continuation notice

There is no such occurrence in your latest “test.odt” document.

test.pdf (28.1 KB)
this is the exported pdf i have
you can check the footnote continuation notice in page 13

OK, I found it. It is an automatic insertion when a note spills over to next page.

This is a bug. What you configure in Tools>Footnotes & Endnotes is prefixed to page number (next or previous depending on the side of the break you are). Consider it a field-like insertion. The bug is: it does not take into account the “nature” of inserted text, its language. The string is laid out unconditionally with the writing direction of the note.

File a bug report. Make a short sample file. Force page size to A6 so that the document is 1 or 2-page long.

1 Like

I added a comment to tdf#160870 and another attachment showing that the bug is even more generic. All field and automatic insertions are affected !

1 Like

Please mark the bug as ‘NEW’

1 Like

@mariosv Isn’t this bug triage responsability?

With your comment, you have confirmed the bug is reproducible, so you can set up it as new, No one special is needed to do it.

It should not be done by the reporter, as happening in this case.