copy/paste doesn't work always

I’m experiencing a problem with libreoffice when i try to copy/paste. IT used to work fine but now i must do it 3 or 4 times before i get it to work. I’m copying words from another document or from the internet and inserting on libreoffice.
What can i do to solve this issue? Any help is appreciated.
Antonio

Thanks for your questions, so here’s the answer: I’m using version 6.4.4.2 (x64) of Libreoffice on Windows 10. When pasting into another program i don’t experience this problem ever. It only happens with Libreoffice. I’m pasting just a few words or a sentence at a time, not large portions of text. I always need to recopy from the source, sometimes 3 or 4 times before it works again. I’ve been using wordpad to counter the issue but i’d like to be able to work again with libreoffice. Between copying and pasting it’s just a few seconds as usual.

@goldenpavilion,

Can you share your LibreOffice version and operating system? (see menu Help - About LibreOffice).

And when you paste in another program…? How many text lines are you copy/pasting each time? Do you need to recopy from the source because it pasted nothing, or only need to paste again? How much time do you leave between copying and pasting?

Edit your question to add more information, or comment an answer. Do not use Answer to comment.

@goldenpavilion,

When did this start happening? When installed LO 6.4.4.2? Does it also happen using Calc?

It started happening a few weeks ago and i can’t understand why, i didn’t change anything. A few days after it started i checked for updates on libreoffice and there were updates needed but it didn’t change a thing. It also happens on Calc!

@goldenpavilion,

See @anon73440385 answer to another question.

There is this complaint also on ask.pt_br

On my computer it worked to uninstall Adobe as a PDF reader.
In fact it is still in the testing phase. Can you check if it works on your computer?

I managed to get to the problem, I pasted the site several times, until the Paste option was inactive, but if I use Ctrl + V it works.

I currently get a similar problem with LO 7.0.4.2 (x64) on Win10 (19042). Pasting from other apps often doesn’t work after the first time unless I restart LO.

I have got a work around which is better than a restart:

  1. Turn on clipboard history in Windows settings

Then whenever pasting stops working:

  1. Copy from the other app

  2. Copy anything inside LO

  3. Ctrl-V to paste it

  4. Ctrl-Z to undo the paste

  5. Windows-V to bring up clipboard history

  6. Paste the previous item copied in step (2), which should be the second item on the history

It works but hopefully the issue will go away in a future release.

Same problem with Windows 10 (19042.867) - currently using LO 7.0.5.2 (x64). It was happening from when I first started using LO after moving from OO about 6 months ago (don’t remember which version I started with, but I used whatever was current at the time and I’ve done a few updates since then and it has happened with all of them). Never happened with OO. I’ve recently reinstalled Windows from scratch and it still happens. I have not installed Adobe since the reinstall, still happens. Hoping for a fix!

@goldenpavilion,

**Ctrl + C to copy and paste without formatting, what is the result?**

I have the same issue! I am running LibreOffice 7.1 with Windows 10. It even happens with the helper program, PureText, which I believe sends a command to the window that has focus to insert the pasted text.

I also have the issue with 7.1.1.2 on Win10 pro
Is there a solution/fix on the horizon?

Same issue, except that I CAN’T paste text AT ALL - whether it has formatting or not. I have 7.1.2.2 on Windows 10.
I can copy and paste into and from an empty browser field, but text is always unformatted (of course).

When will this be fixed? Thanks.

Same problem (Windows 10)

@ducktape, Thanks for your comment. As it don’t solve the question, please, repost it as a comment. To do that, hover on “more” (just above these lines), and select “repost as a question comment”. Thanks.

This problem persists in 7.1.0.3. Things I noticed:

  1. Problem is limited to straight text pasting. For example, copy and pasting from notepad or some other straight text source into LO.

  2. Formatted text pasting still works. For example, copy and paste from html email message or web-page or from some other wordprocessor.

  3. Pasting straight text works exactly once. On a subsequent “copy,” the “paste” menu stays grayed out in LO. Note: pasting into other destinations works, so the text is in the copy buffer, just not seen by LO.

  4. Workaround #1: copy formatted text from another source–don’t need to paste it anywhere, just copy it. You can then copy and paste straight text into LO exactly once.

  5. Workaround #2: downgrade to 6.0. I happened to have the 6.0.2.1 installer still lying around. Uninstall LO and re-install of 6.0 and this “copy & paste problem” just goes away. 5.4 also seems to be totally fine–6.4 is not! (specifically 6.4.5.2). I don’t have all the iterations of LO on-hand between my copy of 6.0 and 6.4, but at some point in-between, copy and paste quit working correctly. As best as I can tell, it is still broken in the latest release (7.1.0.3).

Comment to 4.

Tried that a little bit. Best worked for me to copy&paste the desired text into my browser’s address line, and then recopy it from my browser’s address line and paste into the LibreOffice document.


Version: 7.1.1.2 (x64) / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

Same issue when I upgraded to version 7.2. Worked before, then it didn’t any more. Only affects Writer.

Solution - Uncheck “Outlne Folding.” Tools - Options - LiberOffice Writer - View - Outline Folding.

See also tdf#143813 - Outline folding: copy, cut and paste do not work anymore (but got nothing to do with the original question here and in that sense the symptom may be the same, but the root cause differs and I’m not sure whether you answer will be found, without an own question).