"Could not create Java implementation loader" Zotero MacOS, why?

Hello. I am sorry to re-post something that has been a problem in the past, but I am brand new to LibreOffice and hitting a brick wall.

Working on MacOS 10.13.6 using LibreOffice 7.1.7.2 and trying to activate the Zotero plugin version 5.0.23 - I cannot get the plugin to work and get the error message “Could not create Java implementation loader” when I press “Enable” in the Extension Manager.

I have read through many other questions on this topic, both here and on the Zotero fora so please know I have tried to exhaust every possibility before asking this. As far as I can make out, this is a problem with Java and LO. I know from other posts that I need to install the Java JDK, so have installed the latest 64bit version 17.0.1 - I also updated Java for good measure. As answered elsewhere here, I have checked that LO is loading the correct JRE (it is). Followed advice from the following questions:

At this point I am stumped.

Yes, I have turned it off and on again many times.

Any advice please - where might this be going wrong, or any way to diagnose?

Thank you!

Hi,

You are not the only one being stumped. There is definitely an issue with LibreOffice and Java based plugins and troubleshooting is not easy.

After a previous update of my LibreOffice version, I noticed that the Zotero toolbar was no longer active and the extension manager did not show the Zotero integration either.

Here’s what I did to get things working again:


Make sure LibreOffice is closed.
Start Zotero and go to Preferences > Cite > Word Processors

At that you point you should see that the add-in is either currently installed or not installed.
If not installed, install it. If already installed, click Reinstall LibreOffice Add-in.


  • macOS 10.13.6
  • LibreOffice 7.1.7.2
  • Zotero 5.0.96.3
  • Zotero LibreOffice Integration 5.0.23

Output of java -version in Terminal:
java version “10.0.2” 2018-07-17
Java™ SE Runtime Environment 18.3 (build 10.0.2+13)


Good luck, hope this helps.

Thank you very much for taking the time, I really appreciate the detail that you have included.

I noticed that you’re on Java JDK 18, so I tried installing and using this (I had been working off the stable 17 release). Everything else seems the same for me. Unfortunately, the problem persists and I can’t figure out where it might be going wrong. In fact, now Zotero refuses to install the plugin following the instructions that you give (which I had also followed before) so I have to do a manual install. Regardless, this also didn’t work.

I went back and fully uninstalled Java and the JDK, and Zotero and LibreOffice and performed a full reinstall of each. Maybe something I have tweaked years ago is causing a problem - this machine has been through the wars. For now I think I have to just leave this, and use another Word Processor (frustrating, as I was looking forward to sinking my teeth into LibreOffice at last but referencing is pretty crucial for me when using word processors) or try an install on another operating system (frustrating because my research catalogue is on this machine).

I hope this integration is worked out eventually. LO and Zotero are such perfect companions it is really disappointing not to have it work.