Distracting kerning in LibreOffice 6 on Win10

New Win 10 PC, just downloaded LibreOffice 6. In Writer, the word “their” appears as two words, same for ‘the’ and ‘dammit’ … is there a fix? I looked up other solutions and tried their fixes, which failed. Interestingly, the same issue occurs in Apache OpenOffice. It does not occur in Wordpad or FocusWriter on Windows.

The issue is more pronounced with certain fonts… Courier New seems to work better but the issue is still quite a distraction as it is still looks very weird. I turned ‘pair kerning’ off as well as a similar setting in character/position as suggested by other users. The problem persists. As a developer, I understand that this sort of thing is not an easy fix but the look is so bad as to render the product unusable. The issue does not exist on my new Linux Mint and Manjaro machines.

Quite possibly, as a developer,..., you’re best equipped to sort this one out! :wink: You’ll need to hope someone with Win10 picks this up, so I’ve tweaked your title in the hope it will catch the eye of relevant users. Like you, I don’t have this problem on my machines (OSX and Ubuntu).

Sadly, it seems you’re not alone (and another).

According to fdo#113665 spell-check could be implicated. Have you got it enabled? If so, what difference do you see with/without it? Have you tried toggling “Graphics Output” settings?

The problem is in the screen rendering, not in the kerning.
On Windows 10 (and on my Win 7) the ClearType and DirectWrite implementation is not working properly.
I remember one bug report discussion which said it was simply turned-off because of problems.
I do not know the current state.

I do know that I have the same issues on Windows 7.
In Writer if you view type at the default 12 pt at 100% the character spacing on screen is horrible.
It is even worse if the text is 10pt.
If you slowly zoom in small increments you can see the characters jumping around as they are crammed into pixels.

Zoom in to 200% and the issue is gone.
This is because there are enough pixels now to draw the characters with a better representation of the actual spacing.
Look at any of the problem words at 200-300% and they will look perfect.

On other applications such as those you mentioned, and others like Word, InDesign, QuarkEXpress, the screen rendering is working properly with ClearType and/or DirectWrite and at even smaller sizes the text spacing looks better.

Keep in mind this is a screen rendering problem, not kerning.
You should leave kerning On.
Having kerning Off will affect the quality of your print and PDF output.
This problem will not affect your output to print and to PDF.
In print and PDF the character spacing will be fine.

This problem is very annoying.
I am constantly zooming-in to make sure my text looks right.
Seeing the text jump around is very annoying, and as you say - distracting.

I have no idea of when or even if this problem will be fixed.
Stopped trying to follow all the bug reports when I saw how messed-up this is, and no solution forthcoming.
Sorry to say that for now, as far as I know, we are stuck with it.


This is very sad. More about why it is so here: https://www.reddit.com/r/libreoffice/comments/6mikul/the_kerning_is_pretty_horrendous_in_libreoffice/

Having the same problem. And I’ve tested on 200x zoom it’s gone. Also tried changing Opengl usage and hardware acceleration, no change. Changed anti-aliasing a few times and it kinda fixed a bit, though it was already ticked but apparently not enabled.