Find replace not working

I have a simple file showing several values in a column as follows:

2 pz
4 pz
16 pz

Now, I want to remove pz and keep only numbers. So, I did find and replace function for text " pz" and replace field empty.
The result was very strange - first it removed the number from the cell instead of the text and then on the same cell it removed also text, so the cell remained empty at the end.
I have version 64 bit

Any ideas wht’s wrong here?

[Edit - Opaque] Format input for readability

Can’t confirm on LibreOffice (native TDF packages from, Linux openSUSE Leap 15.2.

image description

Are you accidentally using an Ubuntu 20.04 based Linux system?

I am using Windows 7 and Libre Office 64 bit and it is not working.
Then, on another PC with Linux PureOS/Debian and LibreOffice it is working. Quite strange.

Could you perform the same rest on Windowes 7 while running in LibreOffice Safe Mode (`Help → Restart in safe mode**)? Does this change anything?

Installed on a Windows 10 system and that works as well:

Version: (x64), Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 1; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-US (en_DE); UI: en-US, Calc: threaded

Hence it is either the user profile or the problem is in the combination of Windows 7 + LibreOffice (sadly I got no Windows 7 to perform a test)

I tried in safe mode and it works correctly. Then again I tried in normal mode and it failed and safe mode again was ok.

Hello @Jeff22

according to your test (thanks for that), your LibreOffice user profile seems to be corrupt - therefore reset to factory settings using the following procedure:

  • Start LibreOffice
  • Start in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Archive your profile expanding Advanced (click on the word Advanced right above Help button) and click Archive User Profile button
  • Select option Reset to factory settings
  • Activate [x] Reset entire user profile
  • Click button Apply Changes and Restart

Hope that fixes your issue.

Thanks, it works!

If the answer works for you, please consider to click the check mark (:heavy_check_mark:) next to the answer. Thanks in advance …

I’m having the same problem on a Mac OS 11.2.3 with LibreOffice
I was using find & replace in a document seamlessly until Sunday morning and then it suddenly stopped working. I use this function DAILY and am desperately in need of help. Advice? Thank you :relaxed:

… and, did you follow the procedure shown in the answer?

Thanks, Opaque.
I did not follow those instructions as I assumed they were created for Windows users and I’m a Mac user. I did try exiting out of LibreOffice and restarting the app a few times. I also restarted my entire system twice and neither approach worked. :woman_shrugging:t2:

YAY! Thank you, Opaque! I just tried the instructions above and it worked like a charm. Much gratitude! :relaxed: