help with grand total

I am Still having an issue on a base report and not sure what I have wrong. I have a table for (simplicity here) of 3 fields. One is kit manufacturer, second one is name of kit , 3rd one is price
When I make the report I am trying to get the total of all kits. In the report footer I added a text box and when I go to the properties data tab I click function. When I do my data fields are empty so I can not click price. I was going to use the accumulation function to add all the prices. Any idea why my data fields in the function would be blank? I have a pretty good start to my first project in base however if I can not get a grand total I wont be able to use my information


Model Railroad .odb

Not sure If I did this right but I tried to add the databse

I thought you found the problem? Again, can’t duplicate. Gave you some karma - please add at least a screen shot of the editing of the report if not a sample database. Can’t discern what is wrong from description. Did my sample work for you?

Got it & moved it to your original question. Give me a few to look at it.

So now I’m really confused. There is a report named Query2 which can’t be opened because of an error & queries Query1 and Query2 which have errors. The other query qryGrandTotal works tables seem OK & form seems OK. Is this what I should be seeing?

Yes that is the one disreguard the query and other stuff I am just testing. The problem is I want to have all the prices for each kit add up to a grand total.

what you have is a table with prices for each kit which I need to add so I have a grand total of all kits. Hope this clears things up.

Ok. Found & corrected problems. Problems in Queries - fixed Query1 & deleted Query2. Created new query QueryBuildings. Created report based upon QueryBuildings. This should give you something to review. Based on the errors, you should probably go over some of the documentation: click here.

Repaired DB - ModelRR.odb

Edit: Steps to re-create

  • Open .odb, select Reports section, right mouse click on report name (BuildingCost) and select Edit

  • Select Text Box from toolbar.

  • Draw text box on report footer section by dragging the mouse.

  • Right mouse click text box and select properties (if not already in view)

  • In properties, select Data tab

  • Data Field Type - select Function

  • Data Field - select Price

  • Function - select Accumulation

TEST REPORT! That’s it.

The report is based on the query but it could have been straight from the table.

I believe I just figured out your problem! When you run a report there is a box which says Edit Document. This is NOT what you want. To edit a report, right mouse click on the report name and select Edit. That’s where to make the changes!

ratslinger could you explain the steps to doing this. I tried to recreate what you did from edit and still when I click function on the data tab and try to pick price I do not have anything in the list to pick it is blank.

Thank You Very much I discovered that when I click on data field type I have nothing show up to select. However I was able to type Price in the box and then select Accumulation and it worked. That is what was throwing me off I had no selections show up when I clicked Data field. Not sure why

You have never mentioned your OS or LO version and if Linux if from distro. There are many possible sources for the problem one being something in the profile is messed up. See this post (click here) to fix profile corruption.

Also, If the answer has solved your question please tick the :heavy_check_mark: in upper left of correct answer. This can help others.