How to disable or delay tooltips

Hi there,

I find the display of tooltips very annoying when I hover the mouse cursor over buttons in LibreOffice Writer. It would be ideal if they are only displayed after a certain delay, and not immediately which flickers rapidly as I drag the cursor over the buttons. If this is not possible, then I would like to disable it completely. Can anyone help?

Thanks. Is there no way to delay the tooltip? It’s disappointing if disabling is the only option, as I do like the tooltips when I need them…

No - the timeout is fixed in the code (it is slightly greater - 1.5 s - for extended tooltips though, compared to ordinary tooltips which have 500-ms delay; see OptionsLibreOfficeGeneral, [ ] Extended tips in Help checkbox group).

Converting comments into an answer.

Tooltip appearance timeout is hardcoded in LibreOffice source files, and isn’t configurable. It is, however, different for standard and extended tips (standard tips appear after 500 ms, while extended appear after 1500 ms) - see OptionsLibreOfficeGeneral, [ ] Extended tips in Help checkbox group.

To disable tooltips, you may look at my answer here.

Based on Mike Kaganski’s answers, I found a way to disable tooltips just for the document content.

Tools→Options→LibreOffice→Advanced→Expert Configuration

Here I searched for “tips” in the top search bar.

Double-clicking a row that has a boolean value flips its value. (Highlighted in orange.)

Disabling “ShowContentTips” removes the annoying tooltip from your mouse cursor over the document, but still gives you tooltips over the toolbar buttons.