How to remove single quote in front of numbers in a cell

I have cut and pasted numbers with dollar sign [ $ ] looking like this [ $29,825 ] that are formatted as text. When I format them as “currency” a single quote character [ ’ ] appears in front of them. How to remove the single quote character?
“Find and Replace” command doesn’t find the character.

The apostrophe is not part of the text contained in the cell but only an indicator for the situation that the content is treated as text despite the fact that it could be recognised as numerical.
If allowing RegEx you ‘Search For’ .* (anything) and ‘Replace With’ & (everything found) a new recognition process will be applied with the effect that the content is reciognised as a number and displayed in the chosen (or automatically assigned) format.
If the contents you want recognised are filling a range of a single column you can achieve the result also applying the tool ‘Data’ > ‘Text to Columns…’ (without additional measures).

(There are a lot of threads about the "apostrophe issue"in Calc. Just look for them.)

Also be careful not to use DataText to Columns... if some cells in the range contain formulas (they would be deleted, only the values are retained).

Regards

+1 to @PYS; still, in case of formula, there would not be any apostrophe in the respecting cells’ edit boxes. In my opinion, the Text to Columns is the ultimately correct tool for data conversion (while in case of Find&Replace, the conversion is kind of side effect).

Data > Text to Columns worked fine

Paste complete column in notepad or gedit and the copy back.

In this case, you don’t need an intermediate application; simply paste back as unformatted text (Ctrl+Alt+Shift+V).

Yes Possible.

Just adding the standard FAQ for this.

Not every FAQ subject is settled on this level. In this case the text is very clear and helpful. Having known it 1 1/2 years ago, I surely had simply linked it in.

I only created it half a year ago, so nothing you missed :wink:

Try this - first, get rid of the $ with Find and Replace. Then:

  1. Select the column in which the digits are found in text format. Set the cell format in that column as “Number”.
  2. Choose Edit - Find & Replace
  3. In the Search for box, enter ^[0-9]
  4. In the Replace with box, enter &
  5. Check Regular expressions
  6. Check Current selection only
  7. Click Replace All

This worked for me. It removed the leading ’

Working thanks.

“Search KEY not found”

Make sure Regular expressions is ticked.

You can instead in LO 6 and above, select the column and click Data > Text to columns untick any separators and click OK.

Cheers, Al

As described by @Lupp, the apostrophe is an indicator that a cell is formatted as numeric/date value, but the contents was textual at the moment of setting the format (which could be converted to a number). In this situation, Calc keeps the contents as text (because formatting of an existing value must not do data conversion), and indicates that by showing the apostrophe in edit box.

The proper tool co convert data in Calc is DataText to Columns. One selects (a part of) a column, and starts the tool:

The interface of the tool looks alike CSV import. In the tool, you select the proper type for each column; e.g.,for integers, Standard fits well; if your numbers contain decimal dots (not commas), the proper type is US English; for times, the proper type could be one of dates. Here you may also split texts to several columns using proper separators, and set each resulting column the proper type; or even convert numbers back to text.

The tool is explicitly designed to convert data (as opposed to format data), and I recommend using it wherever one needs such conversion, including “removing the leading apostrophe”, as in this case.

Thank you very much, this is helpful - I did not know such tool existed - it works very well. First set column type and then use the tool on the relevant column. The tool name is a bit cryptic, but that’s fine.