Impress crashes, makes xubuntu session close when loading previously-made presentation

Today, I upgraded my xubuntu version to the latest available (via system-prompt)…

Now, whenever I try to open any presentation I had previously created using LibreOffice Impress, it just closes and the session also closes and I have to log back in…

It opens correctly when I want to create a new slide; but not with the ones I already have created.

Call menu:Help>About LibreOffice … and push the button near “Version Information” which copies the version info into the clipboard like this:
Version: / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: x11
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded

Version: / LibreOffice Community
Build ID: 454130fadb9a820d3728b86ccb63c8f359d70528
CPU threads: 2; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

1 Like

Do not upgrade LibreOffice on Ubuntu! Use the version that is shipped with the distribution! For full functionality you should also avoid “snap” packages.
I do every day’s productive work with LO 6.0 which is the version that was shipped with that old (but still supported) Ubuntu version 18.4. It does everything I want to do.

I use LO 7.3 on Ubuntu 18.4 with the following precautions:

  1. Whenever I install (or upgrade) the most recent community version from the website, I make sure that this version uses another user profile. I open /opt/libreofficeX.Y/program/bootstraprc as root and change the profile path: UserInstallation=$SYSUSERCONFIG/libreoffice/7

  2. Turn off gtk support. I open the start script /opt/libreofficeX.Y/program/soffice as root and add near the POSIX locale declaration: export SAL_USE_VCLPLUGIN=gen

You can find out if your instability is related to a corrupted profile folder (most likely it is): call menu:Help>Restart in safe mode… and click the Help button on the dialog that pops up after restart.

I will re-install the app via synaptic. Thanks for your answers… If the problem persists, I’ll post again.

The “native” office would also suffer from a corrupted user profile.

killall soffice bin
mv ~/.config/libreoffice/4/user ~/.config/libreoffice/4/user.bkp

I don’t understand this.

This kills any running office process (just to be sure) before renaming the user profile.
Now your office suite starts with a new user profile as if it were newly installed. This is the first thing to be checked before blaming the installed packages. If your presentations do run now, you should keep the new profile, walk through the Tools>Options dialog, restore any templates, macros, necessary extensions etc.
Certain things can be restored from the backed up old folder.

See also LibreOffice user profile - The Document Foundation Wiki .

The problem persists. I tried the “safe mode” and got this pop-up window:

I clicked on Open the screen went black and there was a message that read something like ERROR CPU pipe 6 FIF0 underrun.

Hello… I continue to have this problem. I can’t create any new slides not load the ones I had previously created. It crashes, it closes the session and I have to log back in.

I don’t know what’s causing this problem, or how I can fix it.

All I did was upgrade my xubuntu version.


I’ve been trying different ways to have this problem solved or work it out somehow so I can continue to use LO Impress.

I tried using safe mode to open previously-created slides. Didn’t work.
I tried resetting the user profile (via safe-mode options). Didn’t work.
I tried creating a slide and saving it in safe mode. It worked.
I tried opening and editing and saving this new slide. It worked.
Now, I can create new slides and save them normally.
But the old ones I already had, can’t be opened.
Before creating a slide in safe mode and saving it, I wasn’t able to do so in normal mode. I think this, somehow, “fixed” the problem of creating new slides… At least I can now do so. I’ll keep posting if anything happens…
Thanks for your time.

Well, no. It crashed again as I was working on a new slide. :frowning_face:

May it be it’s just a Xfce/X11 problem (especially because it crashes the session which LibreOffice itself should not be capable of…)? You could try with GNOME or another window manager, though that of course would pull in a myriad of dependencies…

Alright. I just found out Writer can crash too.

I downloaded this file

whquestions-speaking-cards-clt-communicative-language-teaching-resources-conv_109087.docx (449.1 KB)

and when I tried to open it, it crashed the same way…

Remove the community version and use the one that is shipped with your distribution.

1 Like

It’s the same thing. No change.

Please upload a sample document which makes your office crash.

NC1 5.1.odp (9.7 KB)

opens as a blank presentation. One slide with no content. But it does not crash my

Version: (x64) / LibreOffice Community
Build ID: a69ca51ded25f3eefd52d7bf9a5fad8c90b87951
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded

nor does it crash my

Version: / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: x11
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded