Keeping bullets together on the page

I have basically the same question as this one from 2012. It didn’t get any responses then, but I’m posting here in the hopes that functionality has been added since then.

In my resume, I have sections formatted like

Acme Corporation            (Heading 2)
My Title                    (Heading 3)
- Something I did           (List Contents + Bullet 1)
- Something else I did      (List Contents + Bullet 1)

The bullets all share common a common paragraph style (List Contents), and this paragraph style is associated with a bullet style (Bullet 1).

I want to set the styles for Heading 2, Heading 3, and List Contents so that this block stays together on the page. Is this possible?

Setting Paragraph > Text Flow > Keep with next paragraph on the headings gets me part of the way there, but still allows line breaks between the elements of the list. Setting the same on List Contents prohibits any line breaks at all, forcing everything that was on the first page of my resume (after the Title element with my name) to page 2.

The default for Headings is Paragraph > Text Flow > Keep with next paragraph so the heading stays with the paragraph immediately following. If it is applied to normal Body text or list paragraph styles then strange things can happen.

If you want to keep each list item together then a table (without borders if desired) will do it, untick the box that says Allow row to split across pages but you might want to allow table to split across pages.

Thank you for the suggestion! This is the workaround proposed in the 2012 thread. I was hoping for a style-based solution akin to the “keep lines together” option in other word processors. How does Writer handle imported MS Word files that use this feature?

Have you a sample of a Word document with the feature? My Word is 2010 and has none of the newest features.

Otherwise you could use keep with next paragraph for a style but the last paragraph of the block would have to have a different style (e.g. List End) without that setting ticked to allow a page break between blocks.
KeepBulletsTogether.odt (39.8 KB)

Turns out I was mistaken about the Word feature: “Keep lines together” applies to the lines within a paragraph but not across entries in a list. This post from the Office forum proposes the same solution as you.

Word 2010 is happy to allow a docx to split a paragraph across the page while the same layout but odt, in Writer will push the entire block to the next page.

There are two settings in Text Flow tab of any paragraph style to create atomic blocks:

  • Do not split paragraph
    Applies to the paragraph to prevent any page break from occurring within the paragraph. The paragraph is shifted to next page if there is not enough space remaining in the current page.
  • Keep with next paragraph
    Manages the relationship between a paragraph and the next one. The paragraph is moved to next page is the following paragraph begins on next page. This setting is usually enabled for headings so that they are not orphaned at bottom of page.

These two settings are cumulative. If you’re not careful enough, you may create a “huge” atomic block with the result of leaving a very large blank space before the page where the block has been pushed. This is what may happen in your resume case if you enable systematically both in your List Contents.

Therefore, though I dislike the idea, I suggest you tune the behaviour with direct formatting (probably only removing Keep with next paragraph) in the paragraphs ending the atomic blocks.