LibreOffice 7.0 not opening on PC Windows 10

My LibreOffice 7.0 isn’t responding when I try to open a doc. I looked in Task Manager, and I can see LibreOffice appear. I ended these tasks and tried again but still no joy. I dis and then reinstalled LO, but the same problem occurred. Finally, I opened it in safe mode, archived my user profile and followed the other instructions that I found here: Libre Office does not run [Solved] However, after doing all that LO still won’t open in normal mode. All of this started after a long update by Windows. I’m pretty sure the cause can found here. Thanks for any help you can offer.

I installed 7.1.6. I have had the same problem and tried a number of the things in this thread, all to no avail.

So I uninstalled and installed the good old version 7.0.6, which worked just as well as I was using it 3 years or so ago.

This problem seems to affect a number of Windows 10 users.

@StewE17 If you go into Tools - Options - LibreOffice - View and turn off Use Skia for all rendering then you will probably be able to install LibreOffice without problem.

Instead, if you go into the archives, you can download and install which won’t have those issues.

Thank you EarnestAI!

That’s got me onto the latest released version.

However Skia does not seem to be mentioned anywhere in this thread until your reply. Graphics rendering options were the furthest from my mind: all I wanted was to start LibreOffice.

This seems to be a bug or omission which may have caused distress to a number of loyal users who may have drifted away to other office products. Perhaps if Skia could be disabled by default from this version onwards, or fixed some other way, this will prevent a lot of wasted time and frustration.

Once again, many thanks.

The first answer directly below is how to disable hardware acceleration. Had you searched for in the search bar at the the top you might found a relevant thread; this one was resolved by unblocking LO in BitDefender anti-virus.

Skia is developed by Google, they don’t have a stable version, just the latest version. On the majority of graphic cards it works fine, in fact, the older version of Skia worked on more cards but Google obviously changed something so that the version that comes with has problems for some cards.


if it starts in Safe Mode and you already tried to reset your user profile to factory settings without success, then perform the following:

  • Right click -> Run on Windows Start menu (or Windows Key + R)
  • Type "%ProgramFiles%\LibreOffice\program\soffice" --safe-mode into Open text field (including the double quotes)
  • Select option [o] Configure
  • Activate [x] Disable hardware acceleration (OpenGL,OpenCL, Vulkan)
  • Click button Apply Changes and Restart

Hope that helps.

OK thanks for that. I tried as you described, and after clicking Apply Changes and Restart, it quickly shut down and opened up again, and I could open a doc. However, when I closed LibreOffice down and clicked on the desktop icon of LO or an odt doc the same old problem reoccurred. It simple won’t open.

I really don’t want to have to go through the above process every time I need to open LibreOffice.

Thanks anyway.

I really don’t want to have to go through the above process every time I need to open LibreOffice.

The procedure is not supposed to be repeated every time, but a result of your problem description, which by your comment turns out to be incomplete. You are talking about “LibreOffice doesn’t open, when clicking on icons I assume to open the application and the related document

Just recreate the icon pointing to LibreOffice, and follow @EarnestAl’s answer.

OK, I have no idea what ‘recreate pointing’ means, however I followed Earnest Al instructions, and it still doesn’t work. Thanks for your input though.

OK, sorry if my problem description isn’t up to scratch but I don’t know much about computing.
I have followed your instructions and Earnest Al’s advice. Are you saying now that I should delete my LibreOffice desktop icon and recreate a new one? I will if you think I should, but I also have desktop icons that are just simple .odt or Word docs and when I click on them, they won’t open either.


  • Right click -> Run on Windows Start menu (or Windows Key + R)
  • Type "%ProgramFiles%\LibreOffice\program\soffice" into Open text field (including the double quotes)
  • Click OK

Does that work, i.e does this start LibreOffice into its Start Center (This is normal mode of LibreOffice)?

Hello Opaque,

Thanks for your time. After following your instructions, LibreOffice opened into it’s start centre.
From this start centre I could then open Writer, Calc etc.

However, on my desktop, I have some documents (i.e. .odt / .doc documents) and when I click on these, nothing happens.

Equally, if I close the LO start centre and then try to open it again by clicking on the LO 7.0 desktop icon or a .odt / .doc document, nothing happens.

Nevertheless, when I look in task manager I can see LO listed as many times as I clicked on the LO desktop icon or an odt / doc document.

Thanks again for your efforts and patience with me. It can’t be easy explaining to a computer dolt like myself.

Ok - so from the result from step above we now know, that your problem is not “LibreOffice doesn’t work”. It does work in normal mode and the problem is with Windows not knowing what to do, when you click an icon - hence

Next-Step (2): Create new icon on your desktop which starts LibreOffice 7.0 (using another version requires adaption)

  • Delete your non-functional LibreOffice starter from your desktop (using Right click -> Delete)
  • Open File Explorer (aka Windows Explorer)
  • Type/Copy %ProgramData%\Microsoft\Windows\Start Menu\Programs\LibreOffice 7.0\ into the address line
  • Right click on entry LibreOffice and select Send To -> Desktop (create shortcut)
  • Optional: Repeat last step for other starters.
  • Test your new shortcut and provide feedback whether the new icon works

image description

OK, I did that, created a new LO icon, but it still doesn’t work. Nor do any of the .odt or .doc files I click on.
LO is still listed in the task manager though for each time I click.

Did you ever reboot your system; do you have Fast Boot enabled, do you use an Software Updater program?

The whole thing is inconsistent…

When you say reboot do you mean restart my computer?
I don’t know what a Fast Boot is. I don’t think I have a Software Updater program. If I did, what would it be called for example?

Could it be Bitdefender or Windows Security that are blocking something?

> When you say reboot do you mean restart my computer?

Yes - I mean a restart of your system.

> I don't know what a Fast Boot is

This is a feature of Windows to get a fast restart / fast reboot. However: This doesn’t in fact completely power off a system and from my perspective this is a complete nonsense that it is a default setting.

> I don't think I have a Software Updater program

There a hundreds of such tools - often come as “plus” (questionable) of antivirus programs. Let’s turn the thing into another question: Did (and do) you download and update LibreOffice from manually?

> Could it be Bitdefender or Windows Security that are blocking something?

Yes - but you told above that disabling Bitdefender doesn’t change anything.

Hello Opaque,

Really sorry, I don’t want to waste any more of your time. I have completely removed LibreOffice and downloaded OpenOffice 4.1.9 instead. It is working just fine.

For reference: I restarted my computer by turning it off completely - lights out - but this didn’t change anything.

Yes, I downloaded LibreOffice from their website by clicking on download LibreOffice.

Indeed, disabling Bitdefender and various elements of Windows Security seemed to have no effect.

I regret leaving LO which has served me so well for so many years. I particularly liked the fact I could get French and Breton language versions as well as English. But needs must, and I didn’t have much choice as I needed it for work.

Thanks again for the help. You’re good people.

Windows Update has caused Windows to lose File Associations.

Click Start Menu > Settings > Apps > Default Apps > Set defaults by app > LibreOffice 7.0 > Manage.

Click on each file type from .odb to .oxt and select LibreOffice as the default to open. Close window when complete

Cheers, Al

[Edit after comment]

By doc you really did mean .doc and presumably .docx, .xls, .xlsx, etc so you’ll have to go back into Set defaults by app and change there.

Or, in File Explorer, right click on a .doc and from the context menu select Open With > Choose another App, in the dialog that opens, select LibreOffice Writer from the list and tick the box that says Always use this app to open doc files, OK. Repeat for any other extensions you need