LibreOffice 7.6.4 install and now it's unusable

Hard to describe what happened after I downloaded and installed the latest version (7.6.4), except to say that Writer is no longer usable. I can’t select any text with the mouse. The screen fractures into chunks of text, making it uneditable. I cannot even save a new document.

So, I uninstalled it and all associated files from my Mac (OS 10.15.7) and installed version 7.5.9, but the problem persists. I can’t recall if that was the version that was working before or not, so please advise if I need an archived version of LO to work with Catalina.

Here is the link to the archive.
I do not know why the newer versions not work on your Mac, and I do not know which version will work.

My tips:

There are some similiar reports in the german part of the site. But if it is not important enough to report this at bugzilla…
One of the persons reverted to wich seem to work.

Thank you kindly. It seems like it was a free RAM issue, not an issue with the software.

I have exactly the same problem - I also installed 7.6.4. and all the problems started.

I then reinstalled 7.5.9 and the Libre Office but it has the same problems as 7.6.4 - yet it was perfectly ok before I installed 7.6.4 - now neither version works!!

Writer is all over the place, the cursor moves but the text stays where it is, I can’t scroll because it the page doesn’t move, then the cursor disappears because I then have 2 pages of text one on top of the other… I agree it’s all over the place - who do we notify??

1 Like

Please test in safe mode, Menu/Help/Restart in Safe Mode

I had exactly the same problem. In the end I installed and its working again.

Thanks for the tip Charlie - all up and running again :+1:t2:

Same problem here using intel Ventura
Unable to select text with the mouse
Loaded as suggested by Charlie7e and it works OK

I have the same problem. 7.5 worked until I installed 7.6. Now both have this problem. It seems to be primarily related to mouse/cursor events. Any attempt to select something messes up the display seriously. Even though the selection actually works, you cannot discern it visually. If you scroll up and back down, the refresh clears it up.

The further weird thing is that it messes up the behavior of versions that previously worked fine. This suggests that it is some kind of configuration or library file that stays around even if LibreOffice is updated (or downgraded).

I am running Ventura OS 13.6.3 on an M2 MacBook Pro.

Hi @paulp575 . Your comment is not related to the original question, MacOS, mouse, etc. please create a new question

Okay; will do that but don’t any place to create a new topic.

Go to the index page and look on the right for the New Topic button

Already found it and posted - thanks.
[Edit EarnestAl]
Question posted at Version Displaying Numerous Errors

I have a similar problem. When I select text, the selection is not visible (but actually it is selected). Scrolling is sometimes erratic. But I can save my documents. I can work, but it is annoying.

Had the same probelms with 7.6.4 and 7.5.9. I went back to 7.5.7.

Just for the record - I have the same problem. More or less workable but very annoying. Will try 7.5.7
2014 macbook pro, 11.7.10.

Curiouser and curiouser! I reinstalled version 7.4.2 (I had carelessly left the installer in my downloads folder for a couple of years). Then decided to attempt a bug report. At that point I reopened 7.6.4 to try and create reproducible evidence - and was unable to reproduce any of the symptoms. Everything worked just fine. So no bug report - which is a shame since it needs to be reported.

Your symptoms summarise my own exactly.
Mac Mini M1 (Apple silicon) OS 13.6.4 LibreOffice
Rolled back to to restore functionality. Thanks Charlie7e :+1:

Following suggestions, I downgraded to and it works fine. Then I upgraded again to 7.5.9. It seemed to work OK at first, but then started having the same problems I reported before. I guess I’ll downgrade back to until this is fixed.

This is the first time I’ve had serious problems with LibreOffice in a very long time. So I hope it is fixed soon.

Here is a followup. I installed the preview release and it seems like this issue is fixed. I’ve quite relieved. So far, no other problems with this release.