Libreoffice base 5.1 for mac java runtime issues


Using a macbook air running os x el capitan 10.11.3

I recently updated to version 5.1 and base can’t find my existed java runtime environment to work.

I updated from 5.0.3 and i have all java updates installed.

Please help me!!!

Thanks a lot!

Sigh. This Java-on-MacOS issue is now somewhat ugly. For LO v5.1 you will require a JDK and not a JRE.[1] I believe it is now necessary to have:

  • Apple-provided JDK v6 installed.
  • Oracle-provided JDK v7 or v8 installed.

These three bug report comments are key to explaining why:

[1] There was an initial JRE workaround available by installing Apple-provided JRE v6 and Oracle-provided JRE v7/v8 but the NeoOffice patch has precluded this option. Also refer tdf#96163.

I just did everything that was said and it does not work!!!

I’ve tried everything that has been suggested and it WILL not work! On my other mac it worked fine, but it is so frustrating for it not to work on a mac my boss was going to use. And if I upgrade mine to a newer LibreOffice, it may not work either.

@marcusen, please indicate the versions of Java and LO you have installed. There are many reports from others indicating the above is effective so there may be some different config on your boss’ laptop that is conflicting. Try starting LO from the terminal with the --backtrace parameter to see if any further details are revealed.

This just worked for me (installing JDK v8) but I did have to go into Preferences → LibreOffice → Advanced and select the JDK before it would work.

I am having trouble as well. I have LO installed on my MACAir with OS X 10.11.6
I just installed JDK v8.102 and have selected that version in the LO Preferences. I have restarted everything. When I attempt to do anything with a Database I have created I get the message:
“Due to unexpected error LO has crashed”. When LO restarts it recovers the database but I can not do anything with the database.

this is also my problem. I have LO NL and jdi-8u102-macosx-x64.
and when i create a database i get the same message Due the unexpected error LO has crashed.

I too had this problem. The documentation says you just need JRE. But neither late vintage Oracle JRE nor v6 JRE from Apples Archives work. You must install the 500MB+ foot print Oracle JDK for LO Base to work. Not a great workaround in my book. As often as Java has updates and its footprint.

BTW, Mac OS X 10.12.2 Sierra, Mid 2012 Macbook Pro, LO v5.2.4.2 Oracle JDK 8 u121

Good morning All – I have this issue: when creating a new database, LO (both and crashes. I can’t create but can open exiting base documents. In Preferences > Advanced I have no Java release listed.
Tried to add in LO -as suggested by Yangchenchick- the path in Java (v8 upd 121) panel of Mac OS (10.12.4 build 16E195) System preferences but it wasn’t accepted.
Any advice?
Many thanks in advance!

Well that really worked !!!

Had already Apple JDK V6 installed and installing JDK 8u74 worked for me.

P.S. Worked also on my Windows 10 laptop.

Thanks again!

Finally. A solution. Thanks. I Also installed JDK 8u74. why is it that an older version works?

Yes! The JDK 8u74 worked for me after trying so many different options. After installing, needed to go into preferences and manually select the radio button for the Oracle JRE.